5

I just made a clean install of Raspbian Jessie, and my WiFi adapter doesn't seem to work. It was working on wheezy.

> lsusb
Bus 001 Device 004: ID 148f:7601 Ralink Technology, Corp.

I did have the firmware /lib/firmware/mt7601u.bin by default

> iwconfig
wlan0     IEEE 802.11bgn  ESSID:off/any
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

/etc/network/interfaces

source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet manual

auto wlan0
allow-hotplug wlan0
iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

allow-hotplug wlan1
iface wlan1 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

I have added the SSID and password in /etc/wpa_supplicant/wpa_supplicant.conf

Can someone help me with this?

EDIT:

On running

sudo ifup wlan0

I get this error:

wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
Failed to bring up wlan0.
3

I do not know the root of the problem but commenting out wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

and using this as configuration seems to work

auto wlan0
allow-hotplug wlan0
iface wlan0 inet dhcp
        wpa-ssid "myssid"
        wpa-psk "password"
  • 1
    What you have listed will work, but calling dhcp will disable dhcpcd and prevent the WiFi widget in GUI from running. You are of course welcome to setup your Pi in any way, but it would be better to get the standard setup working. Your initial question looked like it should work, check any boot messages (or look at dmesg for hints. You may be interested in checking the setup in:- raspberrypi.stackexchange.com/questions/37920/… – Milliways Nov 22 '15 at 22:24
  • did that, followed the steps on the official documentation before trying anything else. dmesg doesnt show any specific errors except [ 15.558404] bcm2708_fb soc:fb: Unknown ioctl 0x40187a22 – tejas Nov 23 '15 at 15:51
  • 1
    raspberry pi 2 with raspbian-jessie the wifi is not working for me either. I've got 4 usb adapters, all can detect the wifi hotspots and their signal strength, but none can actually connect, despite me knowing their password (A desktop and Laptop with Ubuntu and Kubuntu both can connect with wifi just fine though) – user12711 Feb 21 '16 at 7:45
0

I found a solution for me! I bashed my head against a wall for a couple days. I followed all tutorials and still no luck. I installed wicd-curses (which I always use) and it didn't work straight out of the box. Then I poked around a bit in the preferences. I went to the External Programs tab and changed the DHCP from Automatic to dhclient and it worked!

  • 2
    could you state how you changed from DHCP to dhclient? That would be graeat... THX – user54734 Oct 9 '16 at 11:47
0

I just found that with the latest os and the DHCP instead of manual worked out pretty well. i comment out the wpa-conf /etc/wpa_supplicant/wpa_supplicnat.conf and set the ssid and psk to my network.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.