2

I have some problems with the raspicam,can you help me Please?

In fact, It was working without problems since the last month but, yesterday, it starts to display this error when I ran raspistill -o:

mmal: No data received from sensor. Check all connections, including the Sunny one on the camera board

I looked through the different forums and topics, but all the proposed solutions were useless:

I updated the system

tried on 2 raspberry cards and cameras (and checked and changed the cables)

split the memory: 512

overclocked the CPU to medium

On the way, when I run the raspistill command, the raspicam still showing the red light. Also, the card detects the camera and the output of "vcgencmd get_camera" is:

supported=1 detected=1

the output of "raspistill -v" is :

raspistill Camera App v1.3.8

Width 2592, Height 1944, quality 85, filename iii.jpg

Time delay 5000, Raw no

Thumbnail enabled Yes, width 64, height 48, quality 35

Link to latest frame enabled no

Full resolution preview No

Capture method : Single capture

Preview Yes, Full screen Yes

Preview window 0,0,1024,768

Opacity 255

Sharpness 0, Contrast 0, Brightness 50

Saturation 0, ISO 0, Video Stabilisation No, Exposure compensation 0

Exposure Mode 'auto', AWB Mode 'auto', Image Effect 'none'

Metering Mode 'average', Colour Effect Enabled No with U = 128, V = 128

Rotation 0, hflip No, vflip No

ROI x 0.000000, y 0.000000, w 1.000000 h 1.000000

Camera component done

Encoder component done

Starting component connection stage

Connecting camera preview port to video render.

Connecting camera stills port to encoder input port

Opening output file iii.jpg

Enabling encoder output port

Starting capture 0

mmal: No data received from sensor. Check all connections, including the Sunny one on the camera board

I have a raspberry 2 Model B, this is the CPUinfo content:

processor : 0

model name : ARMv7 Processor rev 5 (v7l)

BogoMIPS : 57.60

Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm

CPU implementer : 0x41

CPU architecture: 7

CPU variant : 0x0

CPU part : 0xc07

CPU revision : 5

processor : 1

model name : ARMv7 Processor rev 5 (v7l)

BogoMIPS : 57.60

Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm

CPU implementer : 0x41

CPU architecture: 7

CPU variant : 0x0

CPU part : 0xc07

CPU revision : 5

processor : 2

model name : ARMv7 Processor rev 5 (v7l)

BogoMIPS : 57.60

Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm

CPU implementer : 0x41

CPU architecture: 7

CPU variant : 0x0

CPU part : 0xc07

CPU revision : 5

processor : 3

model name : ARMv7 Processor rev 5 (v7l)

BogoMIPS : 57.60

Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm

CPU implementer : 0x41

CPU architecture: 7

CPU variant : 0x0

CPU part : 0xc07

CPU revision : 5

Hardware : BCM2709

Revision : a21041

Serial : 0000000073c3e333

Can you help me please? Its very important

-1

I have seen a lot of discussion on this error but no real root causes identified.

This amazon reviewer seems to believe it has to do with a WIFI card.

http://www.amazon.com/review/R24IH1QU5Y266L/ref=cm_cr_rdp_perm?ie=UTF8&ASIN=B012ETE75I

  • 1
    However they do not go on to provide any supporting evidence (for that product there was three comments in the approximately six months that it had been on that site and the other two were for positive outcomes) so I do not think we can generalise from that specific case... – SlySven Jan 24 '16 at 4:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.