I'm trying to set up my new-to-me Raspberry Pi (Raspbian Jessie( in a headless manner. I've got the Pi connected to my Mac by an ethernet cable. I am able to login via ssh, but it seems that its IP chances every time I disconnect and reconnect the Pi. I can rediscover the IP using arp -a | grep "b8:27:eb, then use that IP address to ssh in to the Pi.

This is not a viable long term solution for me and I'd have thought that a changing IP would be avoided by connecting the Pi directly to my laptop. In any case it appears that most people have their systems set up so that their Pi is always found on a single IP. I've not found the various 'Static IP' tutorials useful in solving this issue as I am not currently trying to access the Pi through the internet, nor am I connecting to it through my router.

In my System Preferences > Network (MacOS 10.10), I have tried using DHCP and DHCP with manual address. Neither provides an unchanging IP address through which I can login to my Pi, however.

I greatly appreciate any assistance in setting things up so I don't have to keep re-discovering my Pi's IP.

Many thanks, -R


You can easily connect from OS X with ssh pi@hostname.local (the default hostname is raspberrypi). This works without a conventional IP address (it uses link-local address).

If you are directly connecting the Pi to a computer it generally won't get an IP address, unless you have implemented Internet Connection Sharing on the host (which causes other problems).

See How do I set up networking/WiFi/Static IP for more detail.

| improve this answer | |
  • 1
    To explain a bit, both Raspbian and OSX use compatible zeroconf implementations by default (on Raspbian it's called Avahi, on OSX Bonjour) which should provide correct hostname resolution even when using a dynamic IP address on the same LAN. Or at least I think that's one thing it does -- hopefully Milliways will correct me otherwise. – goldilocks Nov 24 '15 at 12:14
  • @goldilocks that is correct. Zeroconf even works on many Windows machines. Only on the latest Raspbian (Wheezy & Jessie) which dhcpcd let ssh work over a link-local address. – Milliways Nov 24 '15 at 22:26
  • Thanks! Using ssh pi@raspberry.local worked perfectly. Since Internet Connection Sharing doesn't work with a direct ethernet connection, is there another way to connect my Pi to the internet through my laptop? – ramesesjd Nov 25 '15 at 5:16
  • @ramesesjd Internet Connection Sharing should work (to let the Pi access Internet) I have used this on my Mac. Unfortunately you can't have ICS and ssh access to the Pi at the same time (without setting up a bridge). If you want to explore this ask on a Mac/Unix support site. It is far easier to connect both the Mac and Pi to a switch/router. – Milliways Nov 25 '15 at 6:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.