2

I cannot launch exe files from EmulationStation if the folder name is too long, contains spaces, or other characters.

For example: I have a folder ~/RetroPie/roms/pc/My Game (1989) [Action] that contains an .exe file

When I change the folder to ~/RetroPie/roms/pc/mygame, the game launches just fine from EmulationStation, otherwise it won't run, it just returns to ES

Any ideas on how to get these to work? I have quite a few abandonware games with folders like this, so the only options I can think of are renaming all of them, or creating symbolic links with more DOS-friendly names (less than 8 characters long, no special characters, etc)

  • Have you tried enclosing the file name/path in quotes? – Steve Robillard Nov 24 '15 at 8:04
  • Yea. Didn't seem to help, even when I used the abbreviated form e.g. MYGAME~1, I just get an invalid path. But they work great if I rename them beforehand. – DWils Nov 25 '15 at 12:31
  • I was actually wondering if LFN folders worked as mount points, and where the script would be that initializes the dos emulator before running it from emulation station, perhaps I could turn the parameter into the C: mount point, then run the exe from C: – DWils Nov 25 '15 at 13:51
1

As commented here and in this forum thread the latest DOSBox 0.74 still lacks long filename support so you should rename the files to 8.3 file names or call the filename ######~1 etc.

In the latest thread however they are working on supporting long file names. You can get the latest code and some binaries on www.dosbox.com/wiki/SVN_Builds. For Linux you could try the SVN builds of Taewoong's page, otherwise try other pages of dosbox.

| improve this answer | |
  • I'll have to follow this. Thanks for the heads up! – DWils Nov 25 '15 at 12:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.