12

Occasionally, when I power up my friendly RPi, the screen stays blank as if there is no output from the HDMI. I can still ssh to the device, so it is working.

Can anyone suggest reasons why it may be happening and how to fix it?

3
  • Are you sure it is just the HDMI output? Have you tried connecting to it with ssh?
    – finnw
    Jun 16, 2012 at 22:36
  • 1
    @finnw I'm sure. I'm connected to it via ssh right now and it's also connected to a blank screen.
    – Jivings
    Jun 16, 2012 at 22:38
  • Now it seems to have stopped working completely...
    – Jivings
    Jun 17, 2012 at 7:34

2 Answers 2

11

This was due to incorrect settings in /boot/config.txt.

Actually deleting the config file solved my issue, but its purpose and possible parameters are documented here.

The contents of my file were:

hdmi_mode=19
#arm_freq=800
disable_overscan=1

This is what comes by default in Arch. The hdmi_mode=19 setting sets the HDMI output to 1024x768 85Hz, which is apparently an unsupported resolution for my monitor.

I believe that deleting the file sets the output to hdmi_mode=1, which is VGA. Clearly this is suboptimal, so I recommend experimenting to find the best value.

0
5

Another possibility I came across is that I didn't get any display unless the HDMI cable was plugged in before the Pi was switched on.

Should be a relatively quick one to fault-find, but worth documenting here nonetheless.

2
  • Confirmed. This also happens.
    – Jivings
    Jun 18, 2012 at 10:33
  • 1
    Could this be solved by using the hdmi_force_hotplug=1 option as documented on elinux.org/RPiconfig?
    – Lekensteyn
    May 13, 2013 at 21:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.