3

My boot time increased if the connected wlan network is not available. If the connected network random_rants is not available it takes more time to boot.

My etc/network/interface configuration is:

auto wlan0
iface wlan0 inet dhcp
    wireless-essid random_rants

__

Listening on LPF/wlan0/0e:20:4e:a5:3d:0a
Sending on LPF/wlan0/0e:20:4e:a5:3d:0a
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 18
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 16
No DHCPOFFERS received.
3
  • This is because the interface waits for DHCPOFFERS. You can speed this up by using a static ip.
    – sinclair
    Nov 24 '15 at 15:46
  • Actually I use my wifi in bot access point and client mode. During AP mode I set static IP. While client mode where I can connect other internet networks, in that I m using dhcp. Just changing static ip during client will reslove the problem ? or having a script at rc folder during boot up to set static IP ? I want to connect the previous connected network when I turn on the device. Does setting static IP will help ? thanks for the reply.
    – Piwarrior
    Nov 24 '15 at 20:16
  • 1
    Others who face this problem I figured out the way actually. I used static IP during the pre-down and pre-up in order to avoid dhcp to stuck for 30seconds timeout till it finds the network. After using static IP boot time is normal as it was earlier. Ö.Ö
    – Piwarrior
    Nov 26 '15 at 14:02
1

This is because the interface waits for DHCPOFFERS. You can speed this up by using a static ip.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.