14

I have successfully loaded up chromium-browser on raspbian jessie and am trying to autostart chromium-browser --kiosk mode... and having no luck. I have tried several attempts with varying syntaxes including @chromium and @chromium-browser (w/out path). Any guidance much appreciated.

In the following directory - I have the following commands: /etc/xdg/lxsession/LXDE-pi/autostart:

@lxpanel --profile LXDE-pi
@pcmanfm --desktop --profile LXDE-pi
@xscreensaver -no-splash
@sh ${HOME}/.config/lxsession/LXDE-pi/autokey.sh
@/usr/bin/chromium-browser --noerordialogs --disable-session-crashed-bubble --disable-infobars --kiosk http://www.website.com
2
  • 2
    Should --noerordialogs be --noerrdialogs? See here Dec 9, 2015 at 11:14
  • June 2018 - Chromium 56 - to suppress any errors it is common to use --incognito
    – SDsolar
    Jun 28, 2018 at 0:36

4 Answers 4

28

For Raspbian (Jessie), this solution worked for me:

Create a new .desktop file in ~/.config/autostart/, e.g.

sudo nano ~/.config/autostart/autoChromium.desktop

Then add the following:

[Desktop Entry]
Type=Application
Exec=/usr/bin/chromium-browser --noerrdialogs --disable-session-crashed-bubble --disable-infobars --kiosk http://www.website.com
Hidden=false
X-GNOME-Autostart-enabled=true
Name[en_US]=AutoChromium
Name=AutoChromium
Comment=Start Chromium when GNOME starts

Then reboot. Chromium should automatically launch in kiosk mode after the desktop has loaded.

See How to Add Startup Programs in GNOME 3.14 on Debian 8 ‘jessie’ for a more detailed explanation.

1
  • 1
    If it helps anyone else - Our Chromium was freezing periodically, so we created a cron job with this command to restart Chromium every hour: 0 * * * * killall chromium-browser; DISPLAY=:0 /usr/bin/chromium-browser --noerrdialogs --disable-session-crashed-bubble --disable-infobars --kiosk "http://www.website.com"&
    – rinogo
    May 18, 2017 at 23:12
7

Raspbian Jessie Chromium boot to fullscreen:

*Loaded Chromium-browser for Raspbian Jessie based on this site: -https://www.raspberrypi.org/forums/viewtopic.php?t=121195&p=818455

*And got the Chromium "boot to fullscreen" from this guidance: site: http://www.0atman.com/auto-start-full-screen-web-page-on-raspbian-jessie-startup.html Create a file called ~/.config/autostart/chromium.desktop with the following contents:

[Desktop Entry]
Encoding=UTF-8
Name=Connect
Comment=Checks internet connectivity
Exec=/usr/bin/chromium-browser -incognito --kiosk YOUR_WEB_ADDRESS

I needed to use Chromium for webrtc live video stream concepts; it looks to be running stable on a V9 codec streams... will try it out w/ H.264/5. I did have epiphany working but would crash after a few minutes of video feeds.

2

Here is a soulution for running a script on startup: Run bash script on startup

You should try to put your command in a bash script. E.g.:

#!/bin/bash
/usr/bin/chromium-browser --noerordialogs --disable-session-crashed-bubble --disable-infobars --kiosk http://www.website.com

Make it executable:

chmod +x {path of the script}/nameofscript.sh

And try this:

sudo update-rc.d {path of the script}/nameofscript.sh defaults
1
  • Thank you. I will try it out and up vote if works on Raspbian-Jessie. I know some has changed between Wheezy and Jessie... but your answer is much cleaner. Appreciate the response!
    – Glenn R
    Nov 27, 2015 at 22:13
2

For Raspian Jessie with Raspberry 3, the right directory for me : ~/.config/autostart

Important : point before config

Because you have several autostart ! For me I use (pi user) : home/pic.config/autostart

2
  • 2
    The right directory for me :/home/pi/.config/lxsession/LXDE-pi/autostart
    – piotr
    Jun 12, 2016 at 10:02
  • 2
    sudo nano .config/lxsession/LXDE-pi/autostart did the trick for me as well.
    – Bram
    Dec 19, 2016 at 21:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.