3

I recently bought a RPi2 and am currently in the process of installing it, but I can't get my Wifi dongle (link in Dutch) working, even though it is supposed to be working "out of the box" and there should be "no need to install extra drivers"... uh-huh... I know there are quite a lot of "I have a WiFi problem"-posts but even after a lot of searching I still can't figure it out so I hope somebody can help me or point me in the right direction.

As to my setup, I did a fresh install of Raspbian and am currently running it with an ethernet cable which enables it to share an internet connection through my laptop (and connect from it to the Pi with SSH), I also have a mouse and monitor (HDMI) connected to try running it without the ethernet/laptop (installed virtual keyboard). The Pi is powered by a 5.2V/2A power adapter.

After the Wifi adapter wasn't picked up on the initial/clean install I updated the Pi with apt-get update/upgrade and rpi-update. As far as I can tell the Pi sees my adapter during bootup, but rejects it at the same time? Drivers seem to be present (8192cu I believe) and up-to-date as well (even tried updating them but got the message "firmware-realtek is already the newest version"). Below are some stats:

uname -a

Linux raspberrypi 4.1.13-v7+ #826 SMP PREEMPT Fri Nov 13 20:19:03 GMT 2015 armv7l GNU/Linux

lsusb (notice the adapter not showing up here)

Bus 001 Device 004: ID 045e:0040 Microsoft Corp. Wheel Mouse Optical
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

lsmod (driver seems to be present?)

Module                  Size  Used by
8192cu                528485  0
cfg80211              419759  0
rfkill                 16659  1 cfg80211
evdev                  10226  2
bcm2835_gpiomem         3023  0
uio_pdrv_genirq         2966  0
uio                     8228  1 uio_pdrv_genirq
i2c_dev                 6040  0
snd_bcm2835            19739  3
snd_pcm                74833  1 snd_bcm2835
snd_timer              18164  1 snd_pcm
snd                    52116  9 snd_bcm2835,snd_timer,snd_pcm
fuse                   81721  3
ipv6                  341380  36

After running sudo dmesg -C, replugging the adapter and typing dmesg I got:

[ 3809.142112] usb 1-1.5: new high-speed USB device number 18 using dwc_otg
[ 3809.243844] usb 1-1.5: New USB device found, idVendor=0bda, idProduct=8176
[ 3809.243872] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 3809.243890] usb 1-1.5: Product: 802.11n WLAN Adapter
[ 3809.243907] usb 1-1.5: Manufacturer: Realtek
[ 3809.243923] usb 1-1.5: SerialNumber: 00e04c000001
[ 3810.022433] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 3810.190677] usb 1-1.5: USB disconnect, device number 18
[ 3810.191263] rtw_cmd_thread: DriverStopped(0) SurpriseRemoved(1) break at line 482

I guess it has something to do with the "link" (whatever that may be) not being ready, but I don't know what it means or how to solve it. Furthermore, ifconfig only shows eth0 and lo (so NO wlan0), and sudo iwlist wlan0 scan results in "wlan0 Interface doesn't support scanning.". So far, I haven't touched the "/etc/network/interfaces". I also tried putting the adapter in all the different USB-slots and even in an externally powered USB hub but all to no avail. I have no idea what else I can do/try and if it wasn't for the mention in the dmesg results I would conclude the adapter is broken (but it is newly bought and does show up so I guess it's a software thingy somewhere).

Any help appreciated! :)

PS. If any extra information is needed let me know and I will post it!

Edit 25/11 - Added a bit of extra info about the way my Pi is connected, and the drivers used for tying it on my laptop (MacBook Pro running OS X El Capitan): first tried the drivers from the Realtek site since the provided minicd with drivers doesn't go into my Mac. When those didn't seem to work I tried these but those resulted in an error during install (next to a warning the thing could break my system). Neither enabled me to find an USB WiFi option in the network tab of the system preferences panel. I'm wondering though, if the adapter would be defect why does it show up in the Pi's dmesg-log and my Mac's System Report?

  • If lsusb does not list the dongle, then it doesn't matter what other files you list. It is unclear from your question how the Pi is connected or what you expect the WiFi to do. You have made life difficult for yourself by running rpi-update. I suggest you make a clean image, and DON'T install unproven bleeding edge software. – Milliways Nov 25 '15 at 2:47
  • ifconfig only shows interfaces that are in an "up" state (not the same as connected, but a prerequisite). ifconfig -a or ip link will show everything regardless. Milliways is right that not having something listed by lsusb is a fatal sign... – goldilocks Nov 25 '15 at 3:52
  • 1
    ...but I'll disagree about the significance of rpi-update -- all it does is update the kernel and pi firmware. Today's "clean image" contains yesterday's "rpi-update" stuff, and the difference is not because they are waiting for the "bleeding edge" to become "proven", but because the images are only released every so often. It could coincidentally make a difference here, but not very likely, and just as easily one way as the other. – goldilocks Nov 25 '15 at 3:52
  • If the you think the adapter is broken try it on another computer. You probably can complain to the supplier. Other wifi adapters should also work, see here – Wilf Nov 25 '15 at 11:40
  • @Milliways as mentioned the Pi is connected with a USB mouse, an ethernet cable (sharing my laptop wifi connection and enabling a ssh-connection), a monitor (HDMI cable) and also a 5.2V/2A adapter for power. As to what I expect the Wifi to do, well.. work? :) I understand your concern about the rpi-update but it wasn't working with the clean image either so I thought let's make sure everything is up-to-date. – Jersebas Nov 25 '15 at 18:14
2

Is there a process by the name ifplugd running on the wlan0? If not it might indicate the adapter is not completely registered with the device.

As a start, you could try installing and connecting to the network through your laptop.

  • As far as I can tell (tried ps and ps axg) there is no such process. I tried installing it on my laptop but no success there either (not sure if that is because of my lack of experience with wifi dongles or the thing is broken). I'll edit the steps I did in my original post – Jersebas Nov 25 '15 at 18:30
  • If it is the only USB Wireless adapter and if there is no entry (wlan0?) under /sys/class/net/, then the OS does not see it which could be the reason as to why you are not able to configure it. – user36965 Nov 26 '15 at 2:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.