1

Hello anyone reading this. I am trying hopelessly to get my Raspberry Pi 2 to output through its 3.5mm 4 pole jack. I have read that is had a option to send video out through that port.

Now I know I have my cabling correct. I have checked it with a meter. I also have a copy of the Raspberry Pi diagram that shows what pole the video is "hosted on". I know very little about how to edit the config.txt so this is just a cry for help because I have spent hours on this and I am lost. So thank you in advance to anyone that responds!

1

You will probably want to check/edit the config.txt file, for these relevant entries, I think; they are shamelessly copied from elinux's RPi pages, just skip typing in the bullet symbol and anything after and including the '#' comment start character:

hdmi_force_hotplug Pretends HDMI hotplug signal is asserted so it appears a HDMI display is attached:

  • hdmi_force_hotplug=1 # Use HDMI mode even if no HDMI monitor is detected

hdmi_ignore_hotplug Pretends HDMI hotplug signal is not asserted so it appears a HDMI display is not attached:

  • hdmi_ignore_hotplug=1 # Use composite mode even if HDMI monitor is detected

sdtv_mode defines the TV standard for composite output (default=0), so use one of:

  • sdtv_mode=0 # Normal NTSC
  • sdtv_mode=1 # Japanese version of NTSC – no pedestal
  • sdtv_mode=2 # Normal PAL
  • sdtv_mode=3 # Brazilian version of PAL – 525/60 rather than 625/50, different subcarrier

sdtv_aspect defines the aspect ratio for composite output (default=1):

  • sdtv_aspect=1 # 4:3
  • sdtv_aspect=2 # 14:9
  • sdtv_aspect=3 # 16:9

So, comment out/remove/set the value to 0 for the first of these, and insert/uncomment/change from 0 to 1 the second (if necessary) and tweak the third and fourth for your geographical/system requirements.

To change these setting on the fly you will probably want to experiment with the tvservice <option>... <arguments>... command (may need to be run via sudo) but as it can change where the local video is displayed from the Pi it is useful to login over ssh and work from there to see the results, also I found in practice that when changing settings for the current display on the Pi it blanks that out and you will want to use a local keyboard to bring the previous contents into view; EITHER: use something like Alt-F2 to switch from VT1 (virtual terminal '1') to VT2 and then Alt-F1 to switch back if using a non-GUI (full screen console) display OR Cntl-Alt-F2 to switch from a GUI to VT2 and then Alt-F1 to return to the GUI (XWindow) display.

Note: the config.txt can contain multiple instances of some of these with different values, I think the last one (that is NOT commented out with a leading #) of each is the one used so it would be wise to comment out the earlier ones to avoid confusing yourself.

1
  • Thank you SlySven for your response!! It worked beautifully! I can not thank you enough for writing such a detailed post. Nov 27 '15 at 14:21
0

As far as I am aware you either have composite output (multi-pole jack) enabled or HDMI output enabled. You can not have both at the same time.

If a HDMI device is detected at boot then the output will be HDMI, otherwise it will be composite.

1
  • Thank you for responding. I do not have any HDMI plugged in currently though. Nov 26 '15 at 23:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.