0

I have a WiFi dongle which has a BCM 43143 chipset I'm running Raspbian Wheezy on my raspberry pi and I've tried everything I found on the internet to fix it the WiFi connection problem I can find the dongle on lsusb but there doesn't seem to be the driver for it in dmesg. I'm not an advanced Linux user and I mostly use Windows. Can anyone tell me where I can find the drivers and how I install them on my raspberry pi? When I run ifconfig, I get an output for eth0 and lo but not wlan0.

lsusb output:

Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 0a5c:bd1e Broadcom Corp.

lsusb -t output:

1-1.3:1.0: No such file or directory
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=dwc_otg/1p, 480M
    |__ Port 1: Dev 2, If 0, Class=hub, Driver=hub/3p, 480M
        |__ Port 1: Dev 3, If 0, Class=vend., Driver=smsc95xx, 480M
        |__ Port 3: Dev 4, If 0, Class=vend., Driver=, 480M

When I run the commands above that is what I get, I'm guessing my device is the one with id 0a5c:bd1e?

sudo ifconfig -a gives:

eth0 Link encap:Ethernet HWaddr b8:27:eb:b4:1d:3a inet addr:192.168.0.11 Bcast:192.168.0.255 Mask:255.255.255.0 UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:254 errors:0 dropped:0 overruns:0 frame:0 TX packets:198 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:19688 (19.2 KiB) TX bytes:27779 (27.1 KiB)

lo Link encap:Local Loopback inet addr:127.0.0.1 Mask:255.0.0.0 UP LOOPBACK RUNNING MTU:16436 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B) But no wlan0

Also sudo ifdown wlan0 gives nothing but

sudo ifup wlan0 gives: -> wpa_supplicant: /sbin/wpa_supplicant daemon failed to start -> run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1 ->Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or directory -> wpa_supplicant: /sbin/wpa_cli daemon failed to start -> run-parts: /etc/network/if-up.d/wpasupplicant exited with return code 1

What is this supposed to mean?

And if this is any more help - when I run sudo ifup wlan0: -> ifup: interface wlan0 already configured

My goal is not functionality but learning.. so how do I install the firmware Many thanks for your help !! :)

  • I use desktop linux systems, and for similar chipsets to that I have to use the wl proprietary Broadcom driver :/ I'm not sure's whether is available for the Pi (or for ARM architectures generally) though. Could you please add the output for lsusb and lsusb -t to your question? (this can be edited in) Also the newer Raspbian Jessie images may work better. – Wilf Nov 29 '15 at 14:48
  • It would appear this is supportable raspberrypi.org/forums/viewtopic.php?t=102458&p=709423 however if you are new to dealing with Linux and your goal is functionality rather than learning you might consider just buying an inexpensive dongle known to be more widely supported by existing pi images. – Chris Stratton Nov 29 '15 at 17:16
  • I have tried the link now... How do I download the firmware on the second link. it says copy into your firmware directory - which one is that? is that all i need to do? – ChK Nov 30 '15 at 17:30
  • It still doesn't recognise the dongle – ChK Nov 30 '15 at 17:31
  • After following every instruction & then rebooting my pi – ChK Dec 16 '15 at 19:51
1

I found that the best way to get this to work was to install raspbian jessie(or latest raspbian distro) on the Pi. Quite simple solution

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.