0

I am currently working with a small Raspberry Pi Model A setup (and want to stick at this model until I can grab a model Zero). It was modified to be as quiet (aka black) on boot as possible which works fine.

So far there is a custom created service starting a video with the hello video demo on boot. Even that works fine and the video is playing nicely.

The problem is I want to get rid of the colored rainbow square on boot because it is the last ugly experience. There is the option to set disable_splash to 1.

But this not only results in a not shown splash screen but also in making the video shown flickering (black diagonal stripes moving over the screen).

What are the detailed influences of disable_splash and how can I get rid of the colored square (disabled or tainted black) while keep the video playing nicely?


Here are only the lines of config.txt which are not commented out

hdmi_group=2
hdmi_mode=87
hdmi_cvt=800 480 60 6 0 0 0
display_rotate=1
config_hdmi_boost=0
gpu_mem=96
disable_splash=1
  • disable_splash=1 should work alright. Not sure why it is not working. May be you can edit your question and include your config.txt so that others can have a look at it. – dhruvvyas90 Dec 2 '15 at 9:28
  • added the modified lines of the config. I tested it on different tiny touch screens in portrait mode (that's why display is rotated) with the same effect, – monty Dec 2 '15 at 9:46
  • raspberrypi.org/forums/viewtopic.php?f=63&t=86781 Have a look at this thread. – dhruvvyas90 Dec 2 '15 at 10:41
  • Good point but I am not sure which part of the discussion you mean. I am not using NOOBS nor Raspbian but a self installed Arch Linux distribution. Since changing the disable_splash changes something it should be the correct file location. Or have you meant the autoboot.txt? – monty Dec 2 '15 at 10:56
  • I can't suggest a "solution", but can hypothesise a cause. I saw this 2 years ago when first using a Pi. I believe it is a magnified 4 pixel image, which is displayed when (or before?) the display is properly configured. It has nothing to do with display_splash. I think I "fixed" it by setting display mode in config.txt. – Milliways Dec 2 '15 at 11:04
2

The upper right corner of the display shows a rainbow colored square, that's a sign of too little power. Get a power supply that delivers more current to RPi.

See these articles for some help:

  • It is not in the top right corner and permanent. It is fullscreen for a second or two on startup. – monty Jan 18 '16 at 14:37
  • When running from a powered USB hub, my RPi showed that graphic, as you describe, full-screen for a brief moment on startup AND showed it in a smaller square after the RPi had been running. Intermittent display: synonymous with power supply at/near threshold to show the indicator. NOTE: once adequate power was provided, intermittent connectivity problems with USB WiFI doodad evaporated. – BarryPye Jan 18 '16 at 21:01
2

If you want to suppress the rainbow square (low power warning) you should edit config.txt:

sudo vi /boot/config.txt

And add the following entry

avoid_warnings=1
  • Thank you for this information. If I would have more reputation I would vote up. disable_splash=1 did it for us but with the mentioned unwanted side effects. – monty Sep 20 '16 at 13:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.