2

I've just run

apt-get update

and

apt-get upgrade

on Raspbian, but when I try

apt-get install python3-gpiozero python-gpiozero

it can't find either package.

Can't find any evidence of needing a non-standard apt-repository. How do I install it?

  • If you are willing to also upgarde to Jesse you can do sudo apt-get dist-upgrade then rerun the above. – Steve Robillard Dec 3 '15 at 23:29
  • ah, thanks Steve Robillard. makes sense. If you add this as an answer I'll accept it. – Hippyjim Dec 4 '15 at 0:10
1

The command you used should work according to the Pi Foundation's recent blog post, however, I tried it and got the same error. I believe doing a dist-upgrade should solve the problem. To upgrade do the following:

sudo apt-get update
sudo apt-get dist-upgrade

then rerun the command to install gpiozero:

sudo apt-get install python-gpiozero python3-gpiozero

If that does not work or you want to upgrade to Jessie this post contains the necessary steps.

  • Thanks, looks like a plan. Only one wrinkle for me - I'm using and old Model B with a 4GB card, not sure it'll all fit. Wish me luck! – Hippyjim Dec 4 '15 at 0:29
  • I would probably get another card and start with a download of Jessie which should have the pizero stuff included. It is safer, but it all comes down to how important the current card contents are and your backup strategy. – Steve Robillard Dec 4 '15 at 0:31
  • Remember that there will be a switch from sysvinit to systemd by default when you change from Wheezy (or older) to Jessie - this might produce some operational differences (especially during start-up) that could surprise you - or, hopefully, it will pass you by without any differences. – SlySven Dec 4 '15 at 9:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.