0

i am new to pi, and i use it as webserver. but every time i dc from ssh, after few hour connect again, pi reject my connect, even use vnc or ssh. what i can do is unplug my power to manual reboot. (truly hurt...)

and my pi using Ethernet network (just beside router), so i am sure not wifi power safe feature cause it. also, my pi haven't plug any usb stick and using 32gb micro sd card as system disk. last, i am using 2v power with plug.

i google for this problem, and try to ping some website every 15min to keep network active, but unlucky, it's fail to save my pi.

i wish i got a solution from you guys, thanks and please forgive my broken english :D

Update : i am using Pi2 and run with Raspbian Jessie, using LAMP as webserver

Ken

5
  • Try reverting back to last configuration where you did not have this issue.
    – grepmaster
    Dec 4 '15 at 2:35
  • hi @grepmaster , i just get my pi for few day only and i din't do any changing.
    – Ken
    Dec 4 '15 at 2:43
  • try checking in /var/log/syslog to see if there's any information that could be of any use
    – grepmaster
    Dec 4 '15 at 2:48
  • You haven't given us any information. What Pi? What OS? Hardware? How did you install webserver?
    – Milliways
    Dec 4 '15 at 3:14
  • @Miliways, i am sorry to miss this information, it's Pi2 in raspbian Jessie. website install by command : apt-get install apache2
    – Ken
    Dec 4 '15 at 3:24
1

I have a wifi adapter that is not reliable on the pi -- or was not, I don't use it there anymore, but when I was doing so I wrote this:

How to automatically reconnect WiFi?

to make it check the internet connection at short intervals and reconnect if necessary.

Note that I've always disabled normal network autoconfiguration stuff which will probably interfere with that; there's an explanation of how to do that here:

How can I disable autoconfigured networking on Raspbian?

Also, in the script from the first link, I'm using an unencrypted network. If you are using a more normal WPA WLAN then use the commands from the second link in place of the iwconfig and dhclient -- but do not put them in subshell parantheses and fork (the ( ... ) &).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.