I own a Sandisk Extreme 4GB Class 10 SD (30mb/s), which used to work fine in my Raspberry Pi (booted Raspbian and Raspbmc), but it has stopped working completely. I have what is known as the "red light dim green" problem, where the green light (OK) is very dim, and the red light (PWR) is on. I own a 2GB SD which works fine in my Raspberry Pi, but it isn't very fast, and I can hardly fit the images I want on it. The SD card problems seems to have started when I installed Adafruit's Occidentalis, but I'm not completely sure. I've tried burning my SD with Win32DiskImager, and Raspbian, as well as using the Raspbmc installer. None of these boot on my Raspberry Pi. It could be something to do with my power supply, but I'm not completely sure. Should the Pi have enough power from a USB 3.0 port? Before, I was using an iPad charger, but I don't have that on hand. Is my SD now dud? (it works fine in the computer)

  • Sounds like a power issue. All you can do is try a different charger and see if it fixes your issue.
    – Jivings
    Dec 8, 2012 at 18:12

1 Answer 1


Replacing my SD card has solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.