2

my Raspberry Pi does turn on and off my TV automatically but the cec-client which can be used from the console does not find any devices. And so i can not control it via the command line.

The output only says: "Found devices: NONE"

I have done the following commands:

apt-get install cec-utils
apt-get install libcec-dev

and also compiled it from the git repository (i did this first of all).

My compile version (the output when running cec-client commands):

libCEC version: 3.0.1, git revision: libcec-2.1.4+223-2f62595, compiled on Sat Dec  5 02:05:25 UTC 2015 by pi@raspberrypi on Linux 4.1.13-v7+ (armv7l), features: P8_USB, DRM, P8_detect, randr

Is there something i could have done wrong? Did i miss something?

P.S.: My RaspberryPi 2 is connected to a Pioneer VSX-528-k

  • Did you ever het this working? – Havnar Feb 6 '16 at 10:52
  • Sorry for responding so late. It works now - i am no more sure why / how i got it working. I think i removed all my cec client packages and reinstalled them directly form the package manager. And be sure to upgrade your raspberry pi too! sudo apt-get update sudo apt-get dist-upgrade sudo rpi-update sudo reboot sudo apt-get install cec-utils -- please try this out – TryToSolveItSimple Feb 8 '16 at 12:15
1

What worked for me was adding the current user (pi) to video group:

$ usermod -a -G video pi

and logging out/in.

1

The cec-utils and libcec packages need to be compiled with "RPi" support to access the raspberry controller. This will show up in the features list usually after randr. It seems the 3.0.1 version in the repository (especially repositories for Ubuntu Mate 16.04-raspberry and above) are completely broken.

My solution: I purged the old versions of cec-utils and libcec3. Then I downloaded the .deb packages from the "Raspbian" repositories and manually installed those. Here are the packages I installed for Mate-16.04 (in this order) 1: libp8-platform2_2.1.0.1~jessie_armhf.deb 2: libcec4_4.0.2.2~jessie_armhf.deb 3: cec-utils_4.0.2.2~jessie_armf.deb

Now it works like a charm and I'm on the latest version (as of this writing). I'm sure you could compile from source, but this seemed shorter to me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.