1

I have Rapberri pi module. It is "Raspberry Pi 1 model B+" and it has Rapbian installed on it

OS Version: Installed OS is Rapbian Jessie (2015-11-21-raspbian-jessie.img)


"Linux Raspberry pi 4.1.13+ #826 PREEMPT Fri Nov 13 20:13:22 GMT 2015 armv6l GNU/Linux"

Issue is: I have leoxsys LEO-NANO150N (RTL8188EUS) wifi adapter and inserted into one of the USB port is Raspberry pi module. After configuring (I have copied all config details in subsequent section) necessary (what i feel) files also it is not working.

Setup details: Ethernet port has lan cable plugged in and works fine (DHCP configured) Plug in wifi adapter into USB port.

Issue Detail: Before configuring wifi setting (in /etc/interfaces and /etc/wpa_supplicant/wpa_supplicant.conf files), things went fine and my pi was accessible via lan ethernet interface, but once i plug in wifi USB adapter, after configuring /etc/interfaces and /etc/wpa_supplicant/wpa_supplicant.conf files, the pi looses connection and i am not able to reach pi via its LAN interface.

But if i takeout USB wifi Adapter the PI is accessible again.

I have checked kernel module for this adapter, it is there and the wifi firmware is also latest and up to date.

But in /val/log/messages i can see the below error

"Dec  3 18:03:04 raspberrypi kernel: [  511.719579] r8188eu: module is from the staging directory, the quality is unknown, you have been warned."

Strange is, i have this module in "/lib/firmware/rtlwifi" path.

pi@raspberrypi:~ $ ls /lib/firmware/rtlwifi
rtl8188efw.bin   rtl8192cfwU_B.bin  rtl8192cufw_B.bin     rtl8192defw.bin  rtl8723aufw_B.bin       rtl8723fw_B.bin
rtl8188eufw.bin  rtl8192cfwU.bin    rtl8192cufw.bin       rtl8192sefw.bin  rtl8723aufw_B_NoBT.bin  rtl8723fw.bin
rtl8192cfw.bin   rtl8192cufw_A.bin  rtl8192cufw_TMSC.bin  rtl8712u.bin     rtl8723befw.bin         rtl8821aefw.bin

Below is /var/log/messages extract

Dec  3 18:03:04 raspberrypi kernel: [  511.504697] usb 1-1.3: new high-speed USB device number 4 using dwc_otg
Dec  3 18:03:04 raspberrypi kernel: [  511.606232] usb 1-1.3: New USB device found, idVendor=0bda, idProduct=8179
Dec  3 18:03:04 raspberrypi kernel: [  511.606274] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Dec  3 18:03:04 raspberrypi kernel: [  511.606293] usb 1-1.3: Product: 802.11n NIC
Dec  3 18:03:04 raspberrypi kernel: [  511.606310] usb 1-1.3: Manufacturer: Realtek
Dec  3 18:03:04 raspberrypi kernel: [  511.606325] usb 1-1.3: SerialNumber: 00E04C0001
Dec  3 18:03:04 raspberrypi kernel: [  511.719579] r8188eu: module is from the staging directory, the quality is unknown, you have been warned.
Dec  3 18:03:04 raspberrypi kernel: [  511.743573] Chip Version Info: CHIP_8188E_Normal_Chip_TSMC_A_CUT_1T1R_RomVer(0)
Dec  3 18:03:04 raspberrypi kernel: [  511.802520] usbcore: registered new interface driver r8188eu
Dec  3 18:03:06 raspberrypi kernel: [  513.655590] MAC Address = 00:13:ef:83:02:64
Dec  3 18:03:06 raspberrypi kernel: [  513.662125] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Dec  3 18:03:06 raspberrypi kernel: [  513.683050] R8188EU: ERROR indicate disassoc
Dec  3 18:03:06 raspberrypi kernel: [  513.695651] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Dec  3 18:03:06 raspberrypi kernel: [  513.715054] ERROR::dwc_otg_hcd_urb_enqueue:505: Not connected
Dec  3 18:03:06 raspberrypi kernel: [  513.715054]
Dec  3 18:03:06 raspberrypi kernel: [  513.765054] usb 1-1: USB disconnect, device number 2
Dec  3 18:03:06 raspberrypi kernel: [  513.765097] usb 1-1.1: USB disconnect, device number 3
Dec  3 18:03:06 raspberrypi kernel: [  513.765354] smsc95xx 1-1.1:1.0 eth0: unregister 'smsc95xx' usb-20980000.usb-1.1, smsc95xx USB 2.0 Ethernet
Dec  3 18:03:06 raspberrypi kernel: [  513.765449] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup
Dec  3 18:03:06 raspberrypi kernel: [  513.821344] usb 1-1.3: USB disconnect, device number 4
Dec  3 18:03:06 raspberrypi kernel: [  513.821714] R8188EU: ERROR indicate disassoc
Dec  3 18:03:06 raspberrypi kernel: [  514.005032] Indeed it is in host mode hprt0 = 00021501
Dec  3 18:03:07 raspberrypi kernel: [  514.414877] usb 1-1: new high-speed USB device number 5 using dwc_otg
Dec  3 18:03:07 raspberrypi kernel: [  514.415128] Indeed it is in host mode hprt0 = 00001101
Dec  3 18:03:07 raspberrypi kernel: [  514.795420] usb 1-1: New USB device found, idVendor=0424, idProduct=9512
Dec  3 18:03:07 raspberrypi kernel: [  514.795483] usb 1-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
Dec  3 18:03:07 raspberrypi kernel: [  514.810878] hub 1-1:1.0: USB hub found
Dec  3 18:03:07 raspberrypi kernel: [  514.811088] hub 1-1:1.0: 3 ports detected
Dec  3 18:03:07 raspberrypi kernel: [  515.104787] usb 1-1.1: new high-speed USB device number 6 using dwc_otg
Dec  3 18:03:08 raspberrypi kernel: [  515.215000] usb 1-1.1: New USB device found, idVendor=0424, idProduct=ec00
Dec  3 18:03:08 raspberrypi kernel: [  515.215042] usb 1-1.1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
Dec  3 18:03:08 raspberrypi kernel: [  515.231918] smsc95xx v1.0.4
Dec  3 18:03:08 raspberrypi kernel: [  515.308929] smsc95xx 1-1.1:1.0 eth0: register 'smsc95xx' at usb-20980000.usb-1.1, smsc95xx USB 2.0 Ethernet, b8:27:eb:f8:3c:37
Dec  3 18:03:08 raspberrypi kernel: [  515.384842] usb 1-1.3: new high-speed USB device number 7 using dwc_otg
Dec  3 18:03:08 raspberrypi kernel: [  515.485952] usb 1-1.3: New USB device found, idVendor=0bda, idProduct=8179
Dec  3 18:03:08 raspberrypi kernel: [  515.485995] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Dec  3 18:03:08 raspberrypi kernel: [  515.486015] usb 1-1.3: Product: 802.11n NIC
Dec  3 18:03:08 raspberrypi kernel: [  515.486034] usb 1-1.3: Manufacturer: Realtek
Dec  3 18:03:08 raspberrypi kernel: [  515.486051] usb 1-1.3: SerialNumber: 00E04C0001
Dec  3 18:03:08 raspberrypi kernel: [  515.487613] Chip Version Info: CHIP_8188E_Normal_Chip_TSMC_A_CUT_1T1R_RomVer(0)
Dec  3 18:03:09 raspberrypi kernel: [  516.815178] MAC Address = 00:13:ef:83:02:64
Dec  3 18:03:09 raspberrypi kernel: [  516.819603] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Dec  3 18:03:09 raspberrypi kernel: [  516.996571] R8188EU: ERROR indicate disassoc

Config details:

pi@raspberrypi:/etc/network $ sudo cat /etc/wpa_supplicant/wpa_supplicant.conf
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
ssid="Mayura Varma"
scan_ssid=1
psk="<mysupersecretpassword>"
proto=RSN
key_mgmt=WPA-PSK
pairwise=CCMP TKIP
auth_alg=Auto


pi@raspberrypi:/etc/network $ cat interfaces
source-directory /etc/network/interfaces.d

auto lo

iface lo inet loopback

iface eth0 inet manual

auto wlan0
allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-ssid "Mayura Varma"
wpa-psk "<mysupersecretpassword>"
#    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

I am wondering that whether both LAN and wifi works togther at same time in rapspberry pi, (yes, it should work) but just am thinking from my pi model and its OS keeping in mind. USB wifi product number is "RTL8188EUS", is it i have to have different kernel loaded into pi? If i see the error, it shows without external power, it works fine, means no need of external powered hub.

Any suggestion on this will really help a lot.

  • Have you looked at this thread : raspberrypi.org/forums/viewtopic.php?f=28&t=62371 ? Also, I have noticed that drivers shipped with newer jessie images doesn't work properly for 8188 eu and it works upon installing custom driver given on that thread or you can just use this github.com/dhruvvyas90/8188eu-drivers-rpi. Hope it helps. – dhruvvyas90 Dec 5 '15 at 14:35
  • You may want to try resetting /etc/network/interfaces to what it was (there's a copy here), and then just configuring the network via wpa_supplicant. Otherwise it may be a driver issue (though it is listed here as working on Ubuntu 15.04 and Arch). – Wilf Dec 6 '15 at 16:39
  • Thanks dastaan, I followed the link provided by you, and installed driver which matches my raspbian kernel. After installing/loading kernel module, it asked me to reboot, hence rebooted my pi, after this, pi is not reachable. But thanks for your reply, it gave me some idea, i will try again and will let you know , Thanks all, i will try all you your idea and will share result – user2196448 Dec 6 '15 at 19:24
  • i tried tried with the driver hosted at github [github.com/dhruvvyas90/8188eu-drivers-rpi], but no luck, the installation went fine, but as soon as i plug in my WIFI USB adapter, pi looses its network connectivity even though the lan cable is connected. I have to take out wifi adapter, then only it i can access pi via network. – user2196448 Dec 13 '15 at 3:19
  • Try it with only the wifi adapter. There are often (route) issues when using both. How far is your wifi from the AP? I just read that it sometimes has issue when they're 'far' apart (although I don't know what they consider 'far'). Another thing you could try is only keep ssid and psk and if you have a hidden SSID, then also keep scan_ssid but remove (or comment out) the other lines in wpa_supplicant.conf – Diederik de Haas Dec 13 '15 at 3:40
3

Your staging driver does not support MAC80211 and that's what wpa_supplicant defaults to.

It probably works if you start wpasupplicant like this:
sudo wpa_supplicant -Dnl80211,wext -c /etc/wpa_supplicant/wpa_supplicant.conf -i wlan0
Optionally without the nl80211 part.

If it does you should find out how to make that permanent. The Arch wiki may be of help: https://wiki.archlinux.org/index.php/WPA_supplicant#nl80211_driver_not_supported_on_some_hardware

  • I've encountered this issue before. This is the most probable reason. He should try to use the nl80211 driver. -Dnl80211 – PNDA Dec 5 '15 at 6:00
  • He could try to find an alternative driver (on github f.e.) which does support MAC80211 and then wpa_supplicant should work without enabling wext. But if he wants to keep using the driver from staging, he'd have to enable wext to get it to work. Just specifying -Dnl80211 (without wext) has no use as that's the default. (Or I just misinterpreted your comment) – Diederik de Haas Dec 5 '15 at 22:00
  • I remember replacing a certain .ko or .so file before. I don't really remember the exact one. – PNDA Dec 6 '15 at 0:14
  • Ahhh. Here we go . Realtek 8188EU drivers: raspberrypi.org/forums/viewtopic.php?p=462982 – PNDA Dec 6 '15 at 0:26
  • Thanks Diederik for you suggestion. i think something is going and and i am missing some steps or i may not be doing something it is required. The steps you have given is not working in my pi and issue still remains... – user2196448 Dec 13 '15 at 3:21
1

Thanks to all who provided suggestions.

The link - https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=62371 provided by dastaan helped to find driver

Solution summary: Install correct driver and have good power adapter for raspberry pi power source (Minimum 1.0A, may be more than that)

Those who wants to know my travel to fix this, below is the details.

Below is the solution -

  1. I have removed driver 'r8188eu' from staging area With my Jessie kernel, the driver r8188eu was placed at staging area and hence it was not allowing to load proper kernel, i got to know from below line entry in /var/log/messages file "r8188eu: module is from the staging directory, the quality is unknown, you have been warned. "

  2. I downloaded respective kernel module "8188eu-20151113.tar.gz" from dropbox site. below is the steps.

wget https://dl.dropboxusercontent.com/u/80256631/8188eu-2015yyzz.tar.gz tar xzf 8188eu-2015yyzz.tar.gz

./install.sh
  1. After this also, the wifi adapter did not work, then I looked at log file and found some unusual logging, below is the extract
Dec 31 15:35:18 raspberrypi kernel: [   14.605372] ==> rtl8188e_iol_efuse_patch
Dec 31 15:35:18 raspberrypi kernel: [   14.775037] ERROR::dwc_otg_hcd_urb_enqueue:505: Not connected
Dec 31 15:35:18 raspberrypi kernel: [   14.775037]
Dec 31 15:35:18 raspberrypi kernel: [   14.775096] ERROR::dwc_otg_hcd_urb_enqueue:505: Not connected
Dec 31 15:35:18 raspberrypi kernel: [   14.775096]
Dec 31 15:35:18 raspberrypi kernel: [   14.775135] ERROR::dwc_otg_hcd_urb_enqueue:505: Not connected

This was logged after loading regulatory domain update as below

> Dec 31 15:35:18 raspberrypi kernel: [   12.976112] cfg80211: World
> regulatory domain updated: Dec 31 15:35:18 raspberrypi kernel: [  
> 12.976160] cfg80211:  DFS Master region: unset Dec 31 15:35:18 raspberrypi kernel: [   12.976175] cfg80211:   (start_freq - end_freq
> @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time) Dec 31
> 15:35:18 raspberrypi kernel: [   12.976205] cfg80211:   (2402000 KHz -
> 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A) Dec 31 15:35:18
> raspberrypi kernel: [   12.976223] cfg80211:   (2457000 KHz - 2482000
> KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A) Dec 31 15:35:18 raspberrypi
> kernel: [   12.976239] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000
> KHz), (N/A, 2000 mBm), (N/A) Dec 31 15:35:18 raspberrypi kernel: [  
> 12.976259] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A) Dec 31 15:35:18 raspberrypi kernel:
> [   12.976277] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz,
> 160000 KHz AUTO), (N/A, 2000 mBm), (0 s) Dec 31 15:35:18 raspberrypi
> kernel: [   12.976294] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000
> KHz), (N/A, 2000 mBm), (0 s) Dec 31 15:35:18 raspberrypi kernel: [  
> 12.976309] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A) Dec 31 15:35:18 raspberrypi kernel: [   12.976327]
> cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm),
> (N/A)

This means, it is able to load driver and get capability information from wifi adapter. This means, driver is perfect and something else is happening.

This made me to think in power perspective, though I have 1.0A capable power adapter for my pi, but it was not pushing that much power to wifi adapter in pi usb port, and hence it was not working proper, and driver detected it as disconnected.

Once I connect my raspberry pi to laptop usb port for power source, things started working

But during this time, I tried all suggestion provided by many people and it made me to learn a lot.

Thanks to all

0

Now is even easier! As per last update on the post https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=62371 already mentioned, MrEngman made a beautiful script, you just need to download and execute it

sudo wget http://downloads.fars-robotics.net/wifi-drivers/install-wifi -O /usr/bin/install-wifi

then

sudo chmod +x /usr/bin/install-wifi

and finally

sudo  /usr/bin/install-wifi

it automatically select the correct driver, downloads it and install.

I have no credits in this, i'm just reporting the last update i can see today (1 sep 2019) on the post here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.