1

I just got my first Raspberry Pi today and I plugged in an Edimax WiFi USB adapter. It flashed blue a few times and then stopped. I am in the desktop and then I look at the upper right hand corner where the WiFi applet is. It says, "No wireless interface found" and it also says, "wlan0 not associated". I ran commands like sudo iwlist wlan0 scan, and I tested if the Pi can detect the adapter. Both seem normal. Everything else like sudo nano /etc/network/interfaces is default. I am running Raspbian Jessie. Please help

  • 2
    What does lsusb | grep -i edimax return? In order to start solving your issue, the exact type of adapter has to be known and the above command should give that. If it doesn't return anything, just run lsusb and copy the line(s) you think should/could be your wireless adapter. – Diederik de Haas Dec 8 '15 at 2:59
  • Update RPI firmware you can do this by following command: rpi-update – U.Swap Aug 3 '16 at 17:55
  • @U.Swap "In normal circumstances there is NEVER a need to run rpi-update as it always gets you to the leading edge firmware and kernel and because that may be a testing version it could leave your RPi unbootable". raspberrypi.org/forums/viewtopic.php?p=916911#p916911 – Milliways Aug 4 '16 at 0:06
2

This worked for me and it took me ages to figure it out http://karuppuswamy.com/wordpress/2012/08/17/how-to-fix-wireless-is-disabled-by-hardware-switch-message-in-ubuntu-12-04/

Network-manager is not used on current version of Raspbian so you can ignore that.

  • Install rfkill: apt install rfkill.

  • Check if the adapter is soft-blocked: rfkill list wlan. If so:

    rfkill unblock wlan
    
-1

In case you haven't already found this guide on the foundation's forum, it's worth a look - https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=44044

I had a similar issue with my original Pi (although not with a recent RPi 2), and the eventual solution was to give it a static IP address as step 4c (setting a static IP address) of the guide.

Need to add some code to /etc/network/interfaces; it should include these lines:

auto wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

And below them we then add

iface default inet static
address 10.1.1.2
netmask 255.255.255.0
gateway 10.1.1.1
  • 1
    Your answer may become of little use if that link stops working. And if the guide is updated (so that step 4c becomes something else), it will become misleading. – Dmitry Grigoryev Oct 18 '16 at 15:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.