-1

When I bought my Pi couple of months ago, I had a set up going where I didn't need any external monitor to work on the Pi while on the go with my Macbook Pro.

I'm usually in the Commandline, but I got X11 forwarding working back then with the following:

  1. Enabling X11Forwarding in /etc/ssh/sshd_config:

X11Forwarding yes
X11DisplayOffset 10

  1. SSH into Pi with `ssh -x @
  2. Start X11 Forwarding with /etc/X11/Xsession

Back then I was on Mountain Lion, and downloaded XQuartz, step (3) worked.

Just got a new MBP running El Capitan, and for whatever reason, step (3) above causes the Pi to pause for a sec, and do nothing, i.e. it looks like the command was executed, and shows command line again for the next command.

Where could I find X11 logs to diagnose this issue? The Xorg logs aren't updated for the X11 forwarding (that I could see).

Or better yet, has anyone got X11 forward working on El Capitan?

Update

For the same purpose, the workaround was tightvnc following this post

  • This might have something to do with lack of X11 on El Capitan. This question is off-topic for this site. – Milliways Dec 6 '15 at 3:57
  • @Milliways. Could you elaborate? A link maybe? – snowbound Dec 6 '15 at 9:20
1

If you have XQuartz installed, and do ssh -X to another computer, XQuartz will start automatically. You can then start X applications in the ssh window, and they'll open on the Mac. You don't need to do the forwarding bits (steps 1 & 3).

Also note, you wrote ssh -x, which means disable tunnelling.

0

It's explained by Apple here: https://support.apple.com/en-us/HT201341

X11 is no longer included in El Capitan, but Apple supports the XQuartz project.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.