0

I have a Raspberry Pi Model B and I updated it this afternoon from wheezy to jessie. I connect headlessly with VNC and SSH (usually the latter) because I play around with home LAMP and nodeJS servers.

Both worked fine before the upgrade. Since upgrading to jessie, SSH has been refusing my connections. The error is:

ssh: connect to host 192.168.2.3 port 22: Connection refused

So, I double checked the IP - no problem there. Then, I checked the hostname and users, both are correct. Then, I tried clearing my RSA keys on both the Mac and the Pi. No luck.

Finally, I checked to make sure the SSH daemon was actually running. And, it wasn't. So, I went through raspi-config and started SSH. I checked again with service ssh status and still got an empty response.

So, my question is: why isn't the SSH service starting and could it have something to do with updating to jessie?

If so, is my only option to reflash with wheezy?

3
  • jessie uses systemd style initialisation rather than whatever was used before. I don't understand either of them. It may have been broken by systemd. However I upgraded to jessie some time ago and don't have that problem. Have you done a full apt-get update/upgrade/dist-upgrade sequence?
    – joan
    Commented Dec 6, 2015 at 9:40
  • This probably the result of the change sysvinit to systemd. Commented Dec 6, 2015 at 9:45
  • 1
    I recently upgraded to jessie, no issue with ssh (which was good, as it's a headless pi) ... the fact that you got an empty response from service ssh status is odd. If you decide to reflash with wheezy, try flashing to jessie instead - you'll lose eveything either way (use a different SD card so you don't) ... to reiterate, ssh on system updated to jessie runs fine Commented Dec 6, 2015 at 11:39

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.