I'm trying to build a "kiosk" app for my Raspberry Pi 2 which has an Adafruit PiTFT connected to it (using their image, which is just the standard Debian Jessie, but with framebuffer stuff added to work with the PiTFT). But no matter what I do, I can't get any app (epiphany or otherwise) to run at startup. I've tried the following:

  • Creating an autostart file in /etc/xdg/lxsession/LXDE-pi/autostart (as well as /etc/xdg/lxsession/LXDE/autostart)
  • Creating a .xinitrc file in ~/
  • Creating an autostart file in /home/pi/.config/lxsession/LXDE-pi/autostart (and /home/pi/.config/lxsession/LXDE/autostart)
  • Using absolute paths (e.g. /usr/bin/lxterminal)

But no matter what I do, nothing seems to run. I've added @lxterminal, a command I know I can run manually from within LXDE, plus I tried my epiphany command (which I can run manually), but upon doing a sudo reboot to restart (which auto-logs me in to LXDE), I get nothing but the standard ol' desktop.

Any suggestions?

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.