1

I'm using Netbeans 8.0.2 with Tomcat 8.0.15 on Raspbian and run some JSP-Projects on it.

The performance of Netbeans is not that great but mostly it does well... until everything crashes. I increased the RAM for Netbeans already:

netbeans_default_options="-J-client -J-Xss4m -J-Xms64m -J-XX:PermSize=64m -J-Dapple.laf.useScreenMenuBar=true -J-Dapple.awt.graphics.UseQuartz=true -J-Dsun.java2d.noddraw=true -J-Dsun.java2d.dpiaware=true -J-Dsun.zip.disableMemoryMapping=true"

I know Netbeans can be quite resource-consuming but there must be a proper way to make it run without these issues...? Am I the only one to whom this happens...?

2

Use a Java 8 JVM (Oracle has the better(faster) implementation for ARM compared to openJDK. download here : Linux ARM v6/v7 Hard Float ABI) so you don't need -XX:PermSize any longer. It was removed with Java 8 and your PermGem Space can no longer be full because it will use the HeapSpace.

Increase -X64ms to -Xms128m or even better -Xms256m. 64MB is not that much for an IDE like Netbeans. You can reduce the RAM used for the GPU to get more RAM for the CPU. Have a look here.

3
  • Thanks for the answer. I'm using the Oracle Version already. PermSize is removed. I stacked up -J-Xms128m as there were some issues with -Xms256m. And in the config.txt I added gpu_mem=32. Let's see what will happen... – Qohelet Dec 7 '15 at 17:41
  • @Qohelet: I would like to know if you get any better with these settings. – Simulant Dec 15 '15 at 12:27
  • Thanks for reminding me - after a week testing the system seems to be more stable. I will try to increase the value again, hopefully it works this time. – Qohelet Dec 15 '15 at 12:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.