I have a USB sound card for my pi b+ which I want to setup as my default sound device and all the tutorials for setting up involve editing the alsa-base.conf file in /etc/modeprobe.d, but I don't seem to have that file! Anyone able to help? I can see the usb fine when i run lsusb, and alsamixer detects it and plays audio fine. I'm running raspbian Jessie.

This is the USB sound card I'm using:


  • What OS and distro are you using? If ausio is playing fne what is the problem? Dec 9, 2015 at 14:41
  • Running Jessie, and i want to set it up so that the usb is the default audio loaded at startup. I'm following this tutorial: lifehacker.com/5978594/… Dec 9, 2015 at 14:44
  • Instead of putting important details in the comments please edit your question and add them there. The problem may be that the tutorial was designed for wheezy (based on the date it was posteed). Dec 9, 2015 at 14:46
  • Edit completed. Do you know what the Jessie equivalent would be then? Or how do I go about setting up the default sound output on Jessie if the alsa-base.conf file is no longer there? Dec 9, 2015 at 14:49
  • You should include that your issue is how to make it the default device. No I do not know the answer, but my comments and your edits will hopefully allow others to answer your question. Dec 9, 2015 at 14:51

1 Answer 1


Turns out the file is now called alsa.conf and is found in /usr/share/alsa. Changed the lines

defaults.ctl.card 0
defaults.pcm.card 0

to card 1 and that's me up and running. Looks like others have different problems with other sound cards so worth looking at other solutions too. Found some good suggestions (including my solution) here:


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.