3

I am having this prob since morning only and before that everything was normal. I can connect to my Pi through ssh using putty on my windows 7. The problem is when I run sudo apt-get update, it gets stuck as shown in the image below. For once I just gave keyboard interrupt (ctrl + C) and re-run to update and let it as it is, first it shows the same thing as shown above and after a long time it shows as shown in the image and gets stuck forever.

enter image description here

My internet connection is working fine, i can ping google.com, gmail.com, even yahoo.com, but when I try to ping 10.10.5.18 it does not connect.

I have searched this forum and googled everything possible. I understand about apt-get update, but nothing has helped me so far.

Please let me know if anybody understands why this is happening and how can I solve this problem.

5
  • 2
    10.10.x.x are intranet addresses (it is not an internet address). Why are you trying to talk to it? Is it a proxy?
    – joan
    Commented Dec 10, 2015 at 9:16
  • Actually every time i do apt-get update it tries to connect 10.10.5.18 as shown in the image. And I am not sure what it is.
    – Sud
    Commented Dec 10, 2015 at 11:34
  • Have a look in /etc/apt/sources.list for the repository address and try pinging by that address by name.
    – joan
    Commented Dec 10, 2015 at 11:41
  • This is what I have in sources.list file deb http://mirrordirector.raspbian.org/raspbian/ wheezy main contrib non-free rpi #Uncomment line below then 'apt-get update' to enable 'apt-get source' #deb http://archive.raspbian.org/raspbian wheezy main contrib non-free #deb http://raspbian.mirrors.wvstateu.edu/raspbian/ wheezy main contrib non-free rpi #deb-src http://archive.raspbian.org/raspbian/ wheezy main contrib non-free rpi And I can ping the mirrordirector.raspbian.org.
    – Sud
    Commented Dec 10, 2015 at 12:26
  • I guess I found the solution. Thanks for point it out joan.. It was my proxy issue, which was the problem. Quiet long back I had set proxy for making it work in my office. I just removed the proxy and voila! its getting updated like smooth.. Thanks Joan Once again.
    – Sud
    Commented Dec 10, 2015 at 12:37

1 Answer 1

2

I guess I found the solution. Thanks for point it out joan.. It was my proxy issue, which was the problem.

Quiet long back I had set proxy for making it work in my office. I just removed the proxy and voila! its getting updated like smooth.. Thanks Joan Once again.

1
  • Please make this as solved. Commented Jan 11, 2016 at 14:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.