4

I'm facing a problem: I can't turn on usb tethering on my phone while it's connected to the pi. The phone says the device is not connected anywhere. The pi also doesn't recognize the device, but the phone battery is charging and the led is glowing on my phone. Do I need some kind of usb driver? I tried with turning usb debugging on and off on the phone. Pi is a Pi2 B with Raspbian Wheezy.

  • 1
    Is there any particular reason you think the Pi supports tethering? – joan Dec 10 '15 at 17:06
  • @joan there is little reason to believe it shouldn't as the utilized usb functionality is very standard. – Chris Stratton Dec 10 '15 at 19:00
  • 1
    it works on x86 and x86_64 linux systems, so unless it isn't available for the Pi's distro due to packaging or ARM architecture it should be possible (AFAIK it just emulates a USB ethernet connector, which you can connect to in settings). You could try installing the libmtp drivers though, that might make stuff work. What phone are you using? Also raspbian jessie may work better (newer software, drivers etc) – Wilf Dec 10 '15 at 20:28
1

According to: https://www.raspberrypi.org/forums/viewtopic.php?t=6543, if your phone supports tethering on raspbian, your phone will be visible as usb0 network device via ifconfig command. Then you may add the line:

iface usb0 inet dhcp 

to /etc/network/interfaces file and finally run the command ifup usb0 to start the connection.

0

I've just tried with my rPI B v2 (not a B+) and my android phone. works like a charm. Just plugged in, turned on tethering on the phone et voila!

a few things you might want to check:

1) does your phone need to turn on tethering ?
2) is your USB cable a data one or just a charging one (it took me some time a few weeks ago to understand why I couldn't connect my phone as a storage unit using a USB cable which turned out to be a charging one)
3) did you enable network over usb on your rPI?
to enable network over usb, run ifconfig to check which usb is providing the tethering. (in my case, usb0) edit the /etc/network/interfaces file to add these 2 lines at the bottom (if usb0):
allow-hotplug usb0
iface usb0 inet dhcp
then restart networking: sudo /etc/init.d/networking restart
and unplug replug your phone

Cheers

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.