2

Recently, I have installed a LAMP server on my Raspberry Pi B+ running Raspbian 7 (Jessie) and when I try to install a plugin or theme it asks for FTP credidentials.

Does anyone know how to fix this?

  • 1
    how did you install wordpress? have you tried using your Pi/raspberry login? What plugin and where are you installing it from? – Steve Robillard Dec 11 '15 at 19:34
  • I installed it onto Apache 2 (Jessie) and it says it cannot connect to ftp.192.168.1.195 and I'm installing it from the wordpress directory. – Caleb Evans Dec 12 '15 at 9:24
  • Is 192.168.1.195 your Pi? Are you doing this through the wp admin panel? or are you actually trying to upload a previously downloaded packeage? – Steve Robillard Dec 12 '15 at 9:29
  • I'm trying to download a theme through the admin panel. – Caleb Evans Jan 6 '16 at 16:41
7

This should be able to be fixed by either providing the FTP credentials in your wp-config.php file (in the root directory of the Wordpress install) or by changing ownership of the Wordpress install. I recommend the changing ownership option.

Changing Ownership

On my Debian WordPress server (not Raspbian, but regular Debian Wheezy), my entire installation is owned by user and group named www-data.

You can check the ownership of your installation with these two lines (hit enter after each one).

cd /var/www
ls -l

That will tell you which user and group owns each file/directory in /var/www. It will be in the form of user:group.

You can change the entire ownership of your installation by:

sudo chown -R www-data:www-data ./[name of Wordpress folder]

That will recursively change ownership and group of everything in your WordPress folder to the user that I am pretty sure Raspbian wants to use.

Changing Credentials

You can define some extra credentials in your wp-config.php file according to a WordPress codex article.

define( 'FTP_USER', 'username' );
define( 'FTP_PASS', 'password' );
define( 'FTP_HOST', 'ftp.example.org:21' );

Though I am not sure if you also then have to figure out configuring the FTP server on the RPi.

Hope this gets you going!

  • Changing the entire ownership of the folder did the trick for me. Much thanks :-)! – user46189 May 7 '16 at 15:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.