0

I have MySQL 5.5 and Python 2.7 installed on RPi. I just need to connect Python to MySQL. I keep reading about MySQLd and MySQL Connector. I think I'd prefer to go with mysqld from what I'm reading, but I can't find a tarball for a version that goes with my installation. I only find old version of mysqld or newer windows exe files. Please help. What am I missing???

  • You probably don't need to bother with that, you can just use a distro package as Vittal's answer strongly hints. – goldilocks Dec 13 '15 at 3:51
1

Will this help?

> apt-cache search python-mysql
python-mysql.connector - pure Python implementation of MySQL Client/Server protocol
python-mysqldb - Python interface to MySQL
python-mysqldb-dbg - Python interface to MySQL (debug extension)
  • Reading the relevant man page will clarify what is going on here if necessary (man apt-cache). – goldilocks Dec 13 '15 at 3:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.