2

I bought the Raspberry Pi 2 B, two days ago. I power it using a 5V 2A USB adapter. To the Pi, I have connected USB keyboard and Mouse(separate USBs), the Ethernet cable, HDMI to HDMI(44-inch LED-LCD TV). OS - Raspbian.

My screen(TV) blacks-out once every 30 seconds. I really dont know why.

  • How long does the screen "black out" for? How do you get the screen to display correctly again? – Jacobm001 Dec 14 '15 at 19:24
  • Just for 1 or 2 second. Then the display comes back up. – Albin Dec 16 '15 at 3:44
1

Two suggestions -- I'd be surprised if the problem is to do with the first one, but try it first.

  1. Have a look at the suggestions here about disabling screen blanking. The reason I'd be surprised if this was it is every 30 seconds seems daft, but again, this is simple to try. You do not actually need to add those to an initrc file, you can first try them straight on the command line and they should take immediate effect, but you may have to install xset first, as per the comments.

  2. Have a look at the HDMI boot settings documented here; they are added to /boot/config.txt (if you are unaware of this file, read that page from the beginning). This is more of a hassle because you have to reboot. Try the hdmi_safe=1 option first. If it works, look at the list of things this implicitly includes, and try with just the first three:

    hdmi_force_hotplug=1
    hdmi_ignore_edid=0xa5000080
    config_hdmi_boost=4
    

    If that works, try removing the middle (ignore_edid) one. If one of these combinations works, you are good to go.

  • I think option 2 is a good suggestion. It sounds, to me, like the TV isn't quite getting the signal it needs to stay awake. – Jacobm001 Dec 16 '15 at 3:46
0

As a matter of fact hdmi_safe=1 implies ALL of these:

hdmi_force_hotplug=1 hdmi_ignore_edid=0xa5000080 config_hdmi_boost=4 hdmi_group=2 hdmi_mode=4 disable_overscan=0 overscan_left=24 overscan_right=24 overscan_top=24 overscan_bottom=24

hdmi_safe=1 worked for me but the 3 metioned by @goldilocks did not.

You can try and tweak the others the same way if the first 3 don't do the trick. The 5 for overscan parameters did nothing but give me the black bars around the image, but the hdmi_mode did.

For hdmi_mode I tried a ton of different values listed in the documentation (specifically here) and ended up using hdmi_mode=5 (which is 1080i/60Hz).

Since I'm on a TV I also set hdmi_group=1.

Good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.