I'm running Jessie on a Raspberry 2, and have setup on the network so it can reach the web and ssh is enabled, but cannot see it on the network. The router shows nothing. I've followed various other questions, updated /etc/hostname and /etc/hosts (this guide). I've tried installing libdns but apt-get was unable to locate package. Tried updating /etc/nsswitch.conf, as well as rebooting the router.

Nothing seems to work. Any idea what I'm missing?

  • How is it connected Ethernet or WiFi? Can you ping it by ip or hostname?what is the output of ifconfig? Please add these details to your question. Dec 15, 2015 at 2:18
  • 1
    Is this a fresh installation of Jessie? Upgrade is not supported. Have you tried the Foundation documentation raspberrypi.org/documentation/configuration rather than the out of date links you listed.
    – Milliways
    Dec 15, 2015 at 3:32
  • It's a wifi connection on a brand new Jessie. Can ping by ip not hostname. Here's the ifconfig. Yes I followed these instructions to connect wifi - no mention of hostname there.
    – geotheory
    Dec 15, 2015 at 4:12
  • I would try and locate it by IP address first, then worry about using the hostname -- which requires some kind of zeroconf service; jessie should have avahi enabled by default for that but it is up to the other computers to use it. Someone across town who knows your name but not your phone number cannot call you; simply yelling "geotheory!" into the receiver is pointless. The fact that you know your name and phone number won't help them. The pi is not the only thing you need to configure.
    – goldilocks
    Dec 15, 2015 at 4:56
  • But I already know the network IP - I can ssh the pi. I'm just trying to make it appear in the router's list of connected devices so I can set port forwarding. It doesn't currently show up..
    – geotheory
    Dec 15, 2015 at 10:50

3 Answers 3


Depending on how your router resolves names It might be helpful to install samba and winbind (even if you're not going to use it). It provides a couple more services that your router might be requiring for device resolution.

sudo apt-get install samba winbind

reboot and check.


I would recommend installing samba as well as it might help your Windows network to pick up the new device.

But nevertheless your router should show the rasperry pi already. My rasperry pi doesn't even have a static ip configured in its network settings. When I installed it, it showed up in the same moment when it got a dynamic IP using DHCP from my router.

Afterwards I created a static entry in the DHCP list of my router. Most of the routers allow you to do that and it maps a given MAC-address to an IP so that you could just leave your device on the dynamic IP setting while always getting the same ip.

You just need the MAC address and/or the current IP of your raspberry pi. All the routers I used (D-Link, LinkSys and Asus) allow you to configure a port forwarding etc. for such a static DHCP IP.


"It's a wifi connection on a brand new Jessie. Can ping by ip not hostname"

Well, there you go. Your Pi isn't in the router's DNS.

Your router probably doesn't provide hostnames to the DNS. My ISP-supplied router has the balls to run dnsmasq but explicitly disable DHCP in it, running a separate DHCP server—which of course doesn't communicate to dnsmasq.

Alternatively, your PI isn't providing a hostname. I forgot to set up my tunnel into my Pi from here, so don't recall which DHCP client it's using. If dhclient, which I think it is, /etc/dhclient.conf should contain:

send host-name = gethostname();

alternatively the following in /etc/network/interfaces

iface wlan0 inet dhcp
    hostname Something

As for libdns and nsswitch, you're not (likely) doing DNS on the Pi so it won't help you (however, if you are running a router like mine that can't be modified, I do have some good hacks to move your local network's DHCP and DNS off the router and onto the Pi).

  • Come to think of it, if you haven't set up anything for the interface, the second option is probably not useful, as it takes the interface out of Network Manager's control.
    – Auspex
    Jan 15, 2016 at 13:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.