0

I previously had Raspbian Wheezy, on which my SSH worked fine. However, on my new version of Jessie I cannot connect the SSH from my laptop to my Pi. I have checked that the SSH is enabled and running, and I am almost certain that there is no problem with the firewall. Does anyone have a solution to my problem?

  • Did you update your existing system or using a new image ? Also, how is RPi connected to network ? – dhruvvyas90 Dec 15 '15 at 13:39
  • can you ping it? What error do you see? – Jakuje Dec 15 '15 at 18:51
  • I am using a new image and ive tried with ethernet, WiFi and a wireless ethernet adaptor. Although, I would like to say that I am a complete newbie to most of the RPi LXterminal commands and what they mean. sorry :) – Kyran Richards Dec 16 '15 at 9:04
  • Which Jessie image did you use? (A link would be useful). The reason I ask? The Jessie Lite image doesn't have an ssh server in it by default(!), so you have to go in and install one (e.g. over serial). Or use the full Jessie image. – lwr20 Feb 13 '16 at 17:37
  • please define "not working" – Havnar Mar 4 '16 at 11:39
2

Is your Pi connected via ethernet LAN?

If so, enter the command in Pi:

ifconfig

Look out for the IP address enter image description here

Using a SSH client (e.g. Putty), enter the IP address, leave the port no as 22, and connect. You should be prompted to enter your Pi password (by default it is "raspberry")

At this stage you should have successfully SSHed into Pi.

I'm using Jessie and no problem accessing Pi via SSH using the method above. If you are accessing via a Wifi dongle then there are different settings you need to perform.

0

Not used Jessie but...

  1. Do you have link lights on the Pi, assuming Ethernet
  2. Do you have the right IP for the Pi
  3. If you can't SSH can you telnet to :22 e.g. 'telnet 1.2.3.4 22'
  4. Nmap your LAN (as root, for manufacturer identification output) and look for RaspPi IP's.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.