6

Also when I try to get the pipe command | using Shift+\ it gives me a tilde '~'. I've tried a different keyboard and those are the only 2 mis-mappings I see.

  • 2
    What distro are you using and what language is your keyboard? If you are using Raspbian then you can remap the keyboard using sudo raspi-config will include a menu item to remap the keyboard. – Steve Robillard Dec 15 '15 at 16:06
  • I was able to ssh into the pi and don't have this problem, so its not a big deal since I will be mostly using it remotely. – SpaceCowboy Dec 15 '15 at 16:23
  • 1
    The fact that it works as expected when you SSH in to the box means that the language and keyboard settings are correct on the machine you are SSHing from. You can check the settings and appl;y them to your Raspberry Pi. – Steve Robillard Dec 15 '15 at 16:30
3

I had this problem a while back, your keyboard language is set to United Kingdom/British instead of USA/United States.

  • bloody roight, mate! I went into the internationalization section and set it back. – SpaceCowboy Dec 18 '15 at 13:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.