1

I bought the amazon basics 4 port powered usb hub(3.0). My Pi0 doesn't recognize anything plugged into it. It is getting power when I plugg the usb WLAN card in I get lights. When I Plug Kbrd/mouse in the usb on the pie they work individually with no issue.

Going through the dmesg I can see that it does notice the WLAN card so it is successfully seeing and reading the hub but (for a lack of better terms) can't fully mount the device and abandons the procedures. Currently at my office and don't have device handy to pull up exactly what all the errors are. Pretty sure it was a -71 error.

I was looking around the net and there were some echo Y > /../..../.../ suggestion out there but that was mainly for a different flavor.

Just looking for some suggestions, I have ordered a couple other hubs so I will try them when they arrive. but this seems to be z comms issue more than a physical issue, so one would think this is fixable.

@Dmitry that was the echo command. Yeah it had no effect. I did plug the hub into a win10 machine and all the ports worked on the hub. The hub lead wire is about 4", just a small piggy tail. I also am running the Pi0 directly to the wall and the hub is on its on power too. With dmesg getting all the information of the wlan card then popping the -71 errors when it moves on to the other ports has me stumped. No matter what order I put the items into the usb hub I'll get the errors in that order. 1.1.1-kbrd -71 1.1.2 wlan I get all the device info 1.1.3 mouse -71.... Switch the order same results. When I plug either the keyboard or mouse in directly to the board dmesg show details of each device with out errors and they function fine.

This one is perplexing bc it should be working with all the devices functioning. I might try headless here next, but this has me tripped up and now I just want to solve it.

  • 2
    USB 3.0 is supposed to be backwards compatible, but have you tried a UDB 2 hub? – Steve Robillard Dec 17 '15 at 19:19
  • @Steve got a couple on the way! Will update when they come. – Sleeper Dec 18 '15 at 4:50
3

Error -71 is a USB protocol error. While it may sometimes be caused by a software or firmware bug, most such bugs are in the past by now. Solutions you find on the net which look like echo Y > /sys/module/usbcore/parameters/old_scheme_first and similar commands are workarounds which were needed before such bugs were fixed. It's unlikely these commands will help you now.

The most likely cause of the error is a physical/electrical issue. Try connecting the hub to the Pi using a different (preferably shorter) cable. Check if the hub is powered properly (i.e. via power adapter, not via the Pi). Also, check if the hub you got works with your PC - chances are the hub is simply broken.

0

I had the same problem, here is what I do:

Connect to the Pi using SSH Run:

sudo apt-get update

sudo apt-get upgrade

While Pi install upgrades follow the shell, it anything not install because of your internet connection run the commands above again. Then reboot using:

reboot

  • I don't see any hints in the question that the author may be running an outdated software. You might as well have suggested to reboot, or to use a better power supply. – Dmitry Grigoryev Nov 30 '18 at 12:14
  • I think you didn't get the point of what I said. I simply mean, sometimes the solution is not too far and a trivial process may solve the problem. – adem Dec 1 '18 at 18:00
  • I (choose to) believe that reasonable people try out trivial solutions before asking. – Dmitry Grigoryev Dec 3 '18 at 10:12
  • Assumption is the mother of all evil. – adem Dec 4 '18 at 1:39
  • I see I can't convince you that your answer is poor. Maybe the votes will. – Dmitry Grigoryev Dec 4 '18 at 8:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.