1

Before, when I launched x from the tty1 console, it would start the x session in tty7, allowing me to terminate it easily from tty1. Now (I do not know what changed it), startx from tty1 will open X in tty1. How can I change it so it will open in tty7?

0

The vt used can be specified as an argument/option when starting the Xserver - it is vt# where # is a number greater than zero and will (must?) be after the display(.screen) number, typically :0 - note that a leading - is NOT used for this option. Depending on the display manager this may be influenced by settings in the configuration for that. For example, the lightdm display manager has a setting in the /etc/lightdm/lightdm.conf file, in the [LightDM] section for minimum-vt which in my case has the default value of 7.

  • My lightdm conf file has 7 for minimum-vt as well. Why isn't X starting in tty7 then? – Rohan Jan 4 '16 at 8:02
  • Not sure, if you do a ps aux | grep vt do you get a line for the X server - it will be something like ... /usr/bin/X -config .... :0 vt# ... - what is the #? – SlySven Jan 5 '16 at 11:32
0

You need to type sudo apt-get purge startx then you need to install it again so you can type sudo apt-get install startx. After you did that you will need to edit the /etc/lightdm/lightdm.conf and set minimum-vt to 7.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.