I have just got a Raspberry Pi Zero. I plugged into the TV using HDMI output but no signal. OS already installed on the SD card.

  • 1
    Welcome to RaspberryPi.StackExchange! Could you elaborate a bit on your setup? What cable did you use to connect? What source is the TV on? How are you powering the Pi? What are the specs of the power supply you use? How did you install Raspbian? Are there any lights on on the Pi and if yes, which ones and are they on solid or flashing? That way we're not guessing as to your setup.
    – Phil B.
    Commented Dec 18, 2015 at 16:28
  • Hey man thanks , power supply came with it , basically I bought the whole kit from pimoroni. I used hdmi cable which I use for sky box and TV is on hdmi source , I even tried it with my PC screen using same hdmi connection but still no result , the kit came with 8GB pre installed OS , and yes green light is blinking , it flashes for few seconds then stay solid for like 2 seconds and goes back to flashing
    – Waqas
    Commented Dec 18, 2015 at 16:37
  • Is that erratic flashing, or is it in a regular rhythm like 5 quick flashes, pause, 5 quick flashes again? The latter will be very obvious so do not overthink it. The former is normal.
    – goldilocks
    Commented Dec 18, 2015 at 16:59
  • Yes that's right it's in regular rhythm of 5 flashes and pause for few seconds
    – Waqas
    Commented Dec 18, 2015 at 17:15
  • @Waqas: That means that start.elf is not found. I would try reinstalling the OS.
    – Jacobm001
    Commented Dec 18, 2015 at 17:25

1 Answer 1


According to elinux's documentation, 5 flashes and a pause from the green LED indicates that start.elf is not found. I would try reinstalling the OS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.