I feel a bit lost about my Raspberry... so I will start at the beginnign to avoid asking the wrong question.

My Plan is: Raspberry can plug in to network via network-Cable -> Works like a charm.
Raspberry gets a Wifi-Dongle to open a WLAN-AP. I basically followed this HowTo, and it worked.
Now, the idea is: The Raspi get a static Ip-adress on it's own WLAN!
That's where I fail.

I seem to have two issues:

  • I cannot get a static IP to the wlan0
  • I am not 100% sure if wlan0 SHOULD be the one with a static ip? Or should br0 be gettign a static?

My Theory is that when I have a 192.168.0.xxx-network already running (from my normal internet-acess), I should be able to open a 192.168.12.xxx-network (12 is just an example... just something that is not 1). Am I right here, and if yes: how do I "explain" that to my Raspi?

PS: I reset the Pi out of desperation and fear to have messed somethign up... currently, hostapd.conf etc do not exist.

Additional Info per comment:
I have the normal ethernet eth0 interface wlan0 , the wifi dongle.
And, per instructions from the linked page, br0, which (as far as I understand it), is supposed to provide the bridge between eth0 and wlan0 so I can connect to the internet via the raspi.

  • Welcome to the Raspberry Pi branch of Stack Exchange! can you clarify what network device is br0? I'd expect you to have "eth0" the wired-ethernet connection and "wlan0" the wireless one (and of course "lo" the local to the machine a.k.a. localhost). I'm not familiar with "bluetooth" but I suppose that might be the name but I do not know.
    – SlySven
    Commented Dec 19, 2015 at 18:04
  • Ah, you are ahead of me now - I wasn't aware of bridging (and I confused it with bonding at first) but I found this Ubuntu manual page at first. I think I may not be the best source of advice on this... but if you are using a "bridge" I am not sure that there will be two "networks" (one either side) it seems to be used to invisibly link the two sides together as one bigger network, but then I'm on shaky ground here - hopefully someone who can explain things will be along shortly.
    – SlySven
    Commented Dec 19, 2015 at 18:16
  • That download for the zipped hostapd executable may be a bit old - it was for a much older version of Linux (2.6.26) - it may be that the bugs that Dave Conroy said that the (first ?) WiFi dongle for Pi that he had then has been fixed by now. I'd try using sudo apt-get install hostapd and see if that works to give you the configuration files including hostapd.conf you expect.
    – SlySven
    Commented Dec 19, 2015 at 18:34
  • Noted! puts that on list
    – Layna
    Commented Dec 19, 2015 at 18:40
  • The currently available hostapd package is 2.3-1+deb8u3.
    – SlySven
    Commented Dec 19, 2015 at 19:02

1 Answer 1


Try editing /etc/network/interfaces and add the following 4 lines:

allow-hotplug wlan0
iface wlan0 inet static

This worked for me

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.