4

I'm trying to connect my Raspberry Pi 2 (Raspbian Jessie, loaded from berryboot) to wifi using my wifi dongle, it's not going as smooth as I had hoped and I'm hoping one of you can help me out.

some more details and undertaken steps:

I plugged in the usb device, couldn't find a wlan so figured i'd reboot for good measure before digging deeper. No success so i did a sudo apt-get update followed by sudo apt-get upgrade. Everything was allready up to date (did my weekly check yesterday allready). still no success so the digging started:

command: lsusb

result:

Bus 001 Device 005: ID 046e:5522 Behavior Tech. Computer Corp.
Bus 001 Device 006: ID 06f8:e032 Guillemot Corp. HWGUm-54 [Hercules Wireless G Ultra Mini Key]
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

so I know it's being recognized correctly. then I tried dmesg | more

[    3.036107] usb 1-1.2: new high-speed USB device number 4 using dwc_otg
[    3.138633] usb 1-1.2: New USB device found, idVendor=06f8, idProduct=e032
[    3.138658] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    3.138675] usb 1-1.2: Product: RTL8188S WLAN Adapter
[    3.138691] usb 1-1.2: Manufacturer: Manufacturer Realtek
[    3.138706] usb 1-1.2: SerialNumber: 00e04c000001

[    5.740346] r8712u: module is from the staging directory, the quality is unknown, you have been warned.
[    5.748177] r8712u: register rtl8712_netdev_ops to netdev_ops
[    5.748220] usb 1-1.2: r8712u: USB_SPEED_HIGH with 4 endpoints
[    5.749442] usb 1-1.2: r8712u: Boot from EFUSE: Autoload OK
[    5.760546] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup
[    6.293467] usb 1-1.2: r8712u: CustomerID = 0x0000
[    6.293499] usb 1-1.2: r8712u: MAC Address from efuse = 00:08:d3:90:bb:a3
[    6.293518] usb 1-1.2: r8712u: Loading firmware from "rtlwifi/rtl8712u.bin"
[    6.294163] usbcore: registered new interface driver r8712u
[    6.295041] usb 1-1.2: Direct firmware load for rtlwifi/rtl8712u.bin failed with error -2
[    6.295069] usb 1-1.2: r8712u: Firmware request failed

Note that on line 4 it says RTL8188S, while there is an issue with firmware R8712u. is this normal that the name doesn't match? or is this 2 different issues?

when i sudo iwconfig

lo        no wireless extensions.
eth0      no wireless extensions.

and when i sudo iwlist wlan0 scanning

wlan0     Interface doesn't support scanning.

when checking nano /etc/network/interfaces i see the following:

# Static network configuration handled by Berryboot
iface eth0 inet manual

auto lo
iface lo inet loopback

anyone have any clue?

edit: doing some more digging, is it possible that running raspbian through berryboot might be the issue?

update: i've modified the file /etc/network/interfaces and /etc/wpa_supplicant/wpa_supplicant.conf to the original as suggested here How do I set up networking/WiFi/static IP address? no luck though but more clues!

command: sudo ifup wlan0

result:

wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
Failed to bring up wlan0.
  • I don't know about Berryboot, but it has changed ` /etc/network/interfaces` from the Jessie default. How, or why (or what else it has changed) - who knows. I wouldn't expect a bootloader to change the configuration. Try restoring to the default as in raspberrypi.stackexchange.com/questions/37920/… – Milliways Dec 21 '15 at 22:53
  • I've tried changing it back to the original, but still no luck. i did try to use the command "sudo ifup wlan0" which resulted in this (adding it to my original post): wpa_supplicant: /sbin/wpa_supplicant daemon failed to start run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1 Failed to bring up wlan0. – MrBramme Dec 22 '15 at 7:09
1

I've managed to "fix" the issue I was having. My aim was to use the wifi adapter on my raspberry pi zero and was using my raspberry pi 2 to test the connection. As mentioned above, there were some issues. I’m pretty sure it has something to do with Berryboot since I installed Rasbian Jessie on my raspberry pi zero and the wifi worked like a charm on the first try. Please note, there is a light on the dongle that I didn’t remember and it did NOT light up while connected to the raspberry pi 2.

I hope this helps anyone who happens to stumble upon this post. My suggestions would be:

  • Remove berryboot
  • Install the newest rabian Jessie image
  • Plug & play :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.