2

Im attempting to setup an rpi via the recovery console ("headless mode") via Mac. I installed the serial port drivers, plugged in the cable (per instructions) and started a session via screen /dev/tty.PL2303-00001014 115200. Up comes the recovery console!

So I want to add networking. I unplug the device, add a cat-5 cable from the router and plug the USB back in. I can see it appear on the router IP list (with corresponding activity on the device) but now the recovery console won't appear. Several tries repeating this sequence to no avail.

More reading about the NOOBS image reveals that it isn't supposed to be setup headless - so next I get to this excellent walk-through. I follow the steps and again - try the serial connection. Still nothing.

Have I damaged the device somehow? It appears to be booting ok (based on LED activity1) and there is network activity.

Some other diagnostic to check?


Edit:

Went back over the directions - found I'd missed a step: make sure the \os\raspbian\data_partition is deleted. Restarted the device and am getting more activity (greed LED). Still no response from the serial port though.

Edit:

Some installation instructions say to restart the Mac after installing the serial driver(s). I haven't done this yet as the device (rpi) has only been 'active' for ~20 minutes. Im going to wait an hour or so and then restart the whole mess.

Final:

The OS install seems to have worked this time. Still no progress from the serial interface but I can SSH to it now. Not really a solution but perhaps an answer anyway.

1Mainly the red LED. The green one was briefly active at power up but not since.

1

If the USBSerial connection is not terminated properly, it might leave the SCREEN program on the mac running. This will cause future connections to block. Try stopping the SCREEN program through a process kill. If it does not work, rebooting the MAC will set it right.

  • I had seen those phantom screen sessions and killed them. Will try a reboot next. Am working on ssh -> wlan0 now. – ethrbunny Dec 24 '15 at 18:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.