0

So, I tried to install chromium on my rPi B+, running raspbian. I encountered 'no installation candidate', and the Internet recommended updating my repo files. So, I did so, expecting the error to be fixed, but lo, 'twas not so. Could anyone tell me what's going wrong and how to fix it?

Below are the terminal results:

pi@raspberrypi ~ $ sudo apt-get update
Get:1 http://mirrordirector.raspbian.org jessie InRelease [15.0 kB]
Get:2 http://archive.raspberrypi.org jessie InRelease [13.3 kB]
Get:3 http://mirrordirector.raspbian.org jessie/main armhf Packages [8,962 kB]
Get:4 http://archive.raspberrypi.org jessie/main Sources [32.5 kB]
Get:5 http://archive.raspberrypi.org jessie/ui Sources [5,197 B]             
Get:6 http://archive.raspberrypi.org jessie/main armhf Packages [101 kB]     
Get:7 http://archive.raspberrypi.org jessie/ui armhf Packages [7,639 B]        
Get:8 http://mirrordirector.raspbian.org jessie/contrib armhf Packages [37.5 kB]
Get:9 http://mirrordirector.raspbian.org jessie/non-free armhf Packages [70.2 kB]
Ign http://archive.raspberrypi.org jessie/main Translation-en_GB               
Ign http://archive.raspberrypi.org jessie/main Translation-en                  
Get:10 http://mirrordirector.raspbian.org jessie/rpi armhf Packages [1,356 B]  
Ign http://archive.raspberrypi.org jessie/ui Translation-en_GB                 
Ign http://archive.raspberrypi.org jessie/ui Translation-en                    
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en_GB        
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en           
Ign http://mirrordirector.raspbian.org jessie/main Translation-en_GB           
Ign http://mirrordirector.raspbian.org jessie/main Translation-en              
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en_GB       
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en          
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en_GB            
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en               
Fetched 9,246 kB in 25s (356 kB/s)                                             
Reading package lists... Done
pi@raspberrypi ~ $ sudo apt-get install chromium
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package chromium is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  chromium-inspector chromium-bsu

E: Package 'chromium' has no installation candidate
pi@raspberrypi ~ $ sudo apt-get install chromium-browser
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package chromium-browser is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'chromium-browser' has no installation candidate
1

As per this link here,

Chromium in Jessie will only install on the ARMv7 RPi 2B model as above link ;)

If you have the ARMv6 RPi 1 models your only option is to install Raspbian Wheezy which has an ancient Chromium version 22 in the repositories.

Looks like either you will have to downgrade to wheezy or use Rpi 2.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.