I am using raspberry pi 2 with Jessie raspbian release. I had installed tightvncserver using following command -

sudo apt-get install tightvncserver

However, when i try to start the server using command line i get following error -

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LC_CTYPE = "UTF-8",
    LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_US.UTF-8").
tightvncserver: Could not create /home/pi/.vnc.

But the server starts when i run command - sudo tightvncserver. Any help on how to fix this issue? Thanks

1 Answer 1


It appears as though your language and locale are not set. Try running sudo raspi-config and under #4: Internationalization Options change the locale to the appropriate setting. As for the reason that using sudo works but not using sudo doesn't is probably that the file that tightvncserver is trying to create:/home/pi/.vnc can't be created with the privileges that you have, but when run as superuser, those permissions errors don't happen. I believe that you always run tightvncserver as root (ie. sudo), although I may be incorrect.

  • I tried setting Internationalization options and locale warning was resolved, but the error from tightvncserver still exists. Not sure why it is asking me to run with root privileges as i didnt install it with root user logged in. Thanks
    – giri-sh
    Commented Jan 4, 2016 at 8:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.