It says the SD card is write protected even if it is in unlocked position. I'm trying to recover lost password by following the instructions here http://www.raspberrypi-spy.co.uk/2014/08/how-to-reset-a-forgotten-raspberry-pi-password/

  • 1
    Why do you need to use a mac to edit it? You can just hold down shift on the RPi while it is booting to enter the recovery system, which is a root terminal. From there you can type nano /boot/cmdline.txt to edit the file. No mac required. Dec 27 '15 at 1:14
  • Just remember to at least sync to ensure the changes are flushed out to the SD Card after the edit - as I cannot recall whether you will have access to the normal shutdown command from the recovery console.
    – SlySven
    Dec 27 '15 at 17:49
  • @PatrickCook Tried with shift, didn't do anything.
    – Ska
    Dec 27 '15 at 21:06
  • I used another MicroSD adapter and it worked right away. Thanks for the tip!!
    – Werner
    Aug 31 '20 at 18:33

You did not remount the root file-system / (with the command mount -rw -o remount /) so you cannot change the /etc/passwd and /etc/shadow files concerned...! Also, in that article, I'd recommend reading the comments as well.


The solution was rather funny, to say the least. The lock switch on SD adapter was not supposed to go all the way into unlock position, but be placed somewhere between 0.5mm and 2mm away from the unlock position towards the middle. Really unbelievable. I hope this saves someone some head scratching.

Not the answer you're looking for? Browse other questions tagged or ask your own question.