I have a wireless keyboard linked to my pi, but when i press the shift key with hash. I get a pound sign instead. How can i solve this as the hash symbol is used a lot for programming and I don't know how to find it otherwise. I have pressed shift and tried every other key on the board. The only other thing i found wasn't right is that shift and the key with two dots one above the othergave me an at symbol. Sorry that all the symbols are written out and not shown but this page said that symbols were a grammatical error and wouldn't let me submit them.

  • What distro are you running? What version? BTW this (:) is called a colon. Dec 27, 2015 at 4:34
  • You may want to clarify your question. I assume you're talking about the £ symbol being displayed (i.e., pound sterling, the British currency). In American English, the # symbol is also called the "pound sign," so your question is a little confusing ("When I press the shift key with hash, I get a pound sign instead.") Dec 28, 2015 at 19:09

2 Answers 2


The problem is that your keyboard is using the default UK mapping. Assuming you are using Raspbian you can use the raspi-config utility to change the keyboard layout. From the command line type sudo raspi-config.

From the menu:

  1. choose option 5 International Options
  2. Then I3 Change Keyboard Layout
  3. Next choose your keyboard model (there are generic choices if your keyboard is not listed - for example I use Logitech generic with my K400).
  4. Then choose the language and country (you may have to choose other first),
  5. finally click OK to select the default selection for the remaining options.
  6. Click finish and reboot.

Your Pi is set up for a UK keyboard but your phyiscal keyboard is a US keyboard. Unfortunately this isn't just a layout difference, UK keyboards have one more key than US ones.

On the raspberry pi foundation raspbian image you should be able to fix this using raspi-config. Other systems may vary.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.