2

This question already has an answer here:

I have Raspberry Pi 2 with Jessie raspbian release. I had installed tightvncserver using command -

sudo apt-get update
sudo apt-get install tightvncserver

Once i had installed the server it was working fine until i restarted my pi. After restarting when i run command to start vnc server using tightvncserver command, i get following error -

pi@raspberrypi:~ $ tightvncserver
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LC_CTYPE = "UTF-8",
    LANG = "en_GB.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_GB.UTF-8").
sh: echo: I/O error
Couldn't start Xtightvnc; trying default font path.
Please set correct fontPath in the tightvncserver script.
sh: echo: I/O error
Couldn't start Xtightvnc process.

NOTE: I am getting an I/O Error and there is no issue with creating .vnc file

I couldn't see anybody getting this issue. Any help would be appreciated.

marked as duplicate by Milliways, Ghanima Jan 12 '16 at 8:40

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

from this post on Ask Ubuntu:

Couldn't start Xtightvnc; trying default font path.
Please set correct fontPath in the vncserver script.
Couldn't start Xtightvnc process.

Solution: The x11 fonts are missing, I don't know why the dependency packages are not installed. Try to find folder

ls /usr/share/fonts/X11/

if it is not found, then try to install xfonts base

apt-get install  xfonts-base
  • I tried with this solution. But still i get an I/O error. Not sure whats wrong with my config. I seemed to have messed up my config files. Tightvncserver doesn't start without root permission anymore. Thanks. – Girish Sortur Dec 28 '15 at 17:25
  • Try removing configuration files, they will reset to defaults and hopefully things will work. – randomdude999 Dec 28 '15 at 17:27
  • Sure. will try that. However, i wasn't able to restore /home/pi/.vnc/xstartup file. It somehow got deleted. Thanks – Girish Sortur Dec 28 '15 at 17:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.