On boot I'm getting to the line

[OK] Setting kernel variables ... done

A few lines before that there is a failure

[....] Mounting local file system...[    14.601764] mmc0: missed completion of cmd 18 DMA (512/512 [1]/[1]) - ignoring it
[    14.914927] mmc0: DMA IRQ 6 ignored - results were reset

The changes leading up to the this were that I installed upstart and then tried to reboot (sudo reboot). The reboot command didn't error, it also didn't do anything, no output to the screen like "Hey I'm about to reboot!" or whatever the normal message is. I tried the command a few more times, and then pulled the plug. I've been getting the above or simply a failure to load the file system ever since.

How can I fix this?

Output from fsck (3.9GB part, ext4):

Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information

   66856 inodes used (28.14%)
      25 non-contiguous files (0.0%)
      93 non-contiguous directories (0.1%)
         # of inodes with ind/dind/tind blocks: 0/0/0
         Extent depth histogram: 51823/14
  386579 blocks used (40.76%)
       0 bad blocks
       1 large file

   46850 regular files
    4498 directories
      12 character device files
      25 block device files
       2 fifos
     594 links
   15460 symbolic links (14972 fast symbolic links)
       0 sockets
   67441 files

59MB part, vfat:

Checking we can access the last sector of the filesystem
Boot sector contents:
System ID "mkdosfs"
Media byte 0xf8 (hard disk)
       512 bytes per logical sector
      8192 bytes per cluster
        16 reserved sectors
First FAT starts at byte 8192 (sector 16)
         2 FATs, 16 bit entries
     16384 bytes per FAT (= 32 sectors)
Root directory starts at byte 40960 (sector 80)
       512 root directory entries
Data area starts at byte 57344 (sector 112)
      7161 data clusters (58662912 bytes)
63 sectors/track, 255 heads
         0 hidden sectors
    114688 sectors total
Reclaiming unconnected clusters.
/dev/sdd1: 11 files, 2109/7161 clusters
  • That error shouldn't be fatal. Is that the only one?
    – Jivings
    Dec 16, 2012 at 18:51
  • Sometimes I get [FAIL] Mounting local filesystem...failed
    – Matt Ellen
    Dec 16, 2012 at 19:42
  • 2
    It sounds like there are I/O problems with the SD card. I would recommend running fsck on the partitions with the card plugged into another *nix machine firstly, otherwise, try another SD card.
    – Munkeh
    Dec 16, 2012 at 19:43
  • @Munkeh I've added the fsck output. Not getting any further in the boot, sadly.
    – Matt Ellen
    Dec 16, 2012 at 20:01
  • 1
    That's an issue with upstart, which I'm not familiar with, sorry. I would revert back to sysinit or use systemd for a fix.
    – Munkeh
    Dec 16, 2012 at 20:21

1 Answer 1


This probably means that your file system is corrupted. You will need to re-install Raspbian.

  • 1
    A successful fsck belies this. I agree with with the comments above that the SD card was corrupted, or that the card was slightly incompatible with the current firmware.
    – Fred
    Mar 16, 2014 at 21:02
  • Usually, reinstalling is the last option. Please don't suggest that someone do that unless other answers have been suggested and have failed. Mar 28, 2014 at 22:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.