3

I just got my Raspberry Pi 2 today, and I installed Kali linux on it, but now I want to get my PiTFT screen working. I cannot get it to work.

I'm following this tutorial, Configuring the PiTFT.

When I put this in my terminal:

wget http://adafruit-download.s3.amazonaws.com/adafruit_pitft_kernel_1.20150420-1.tar.gz

I get this error:

Error 403: forbidden

Can someone please tell me how to fix this and properly install my PiTFT screen?

Also when I fill in this:

mount /dev/mmcblk0p1 /boot

nothing happens.

0

Well I am able to download the file to a GNU/Linux (Debian) PC, and Wikepedia's article on 403 responses suggests there is something about that request that the Server didn't like. Maybe it is not happy serving the file to a command-line wget from a Pi (might want feeding with a download-tracking cookie or some other thing that a browser does that wget doesn't bother with / avoids).

Also, if the mount command succeeds then there isn't anything for it to moan about and unless you use the --verbose or -v arguments there is no output!

0

As already mentioned, the server didn't like something. I got it to download on my pi. Try replacing wget with iceweasel, and see if it downloads then.

Mount doesn't output anything (unless an error occurs), so that means it in fact did work.

0

That kernel package and these instructions are outdated. The best guide to Kali Linux on Raspberry Pi 2/3 with Adafruit PiTFT can be found on the "Sticky Finger's Kali-Pi" website:

http://whitedome.com.au/kali-pi

It has everything your need to make it work. It also has the newest kernel for Raspberry 3 support and wifi injection patch.

Have fun, Re4son

0

Me too had the same problem with PiTFT. I tried a lot with raspbian, but didn't worked.

But Jessie based OS worked out of the box.

Here is the download link and steps.

Download: https://adafruit-download.s3.amazonaws.com/2016-03-25_Jessie_PiTFT35r.zip

tutorial : https://learn.adafruit.com/adafruit-pitft-3-dot-5-touch-screen-for-raspberry-pi/easy-install

0

I believe that this kernel is outdated now, but I just tried the wget command from my linux laptop and it worked. I just double-checked, and I typed in what you had. Perhaps there was a glitch in the server, or it wasn't up for a short while.

Whatever it was, the server and network and stars aligned right for me tonight.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.