6

Thanks to help received in here, I was able to get RCA video out of my Raspberry Pi 1 version B with NOOBS.

With Raspian (installed via NOOBS) all I had to do was editing the config.txt file to comment out hdmi_force_hotplug=1 and uncomment sdtv_mode=2 lines. All is fine and dandy. After that, Raspian was able to show the desktop on TV.

Now, OpenELEC with Kodi is a different beast. I was able to log in via SSH to modify both config.txt files (the one in boot and the one in boot-rp1) to reflect the same changes as above but...

No video output at all. I get a slight flicker at boot, I can hear sound but... the screen is dark. Even if I add hdmi_ignore_hotplug=1. I though I verified the files have been changed (even the one that can be seen from the recovery menu of Noobs reflects such changes).

But...where is the right config.txt for OpenELEC? There is one each in

  • /var/media/boot
  • /var/media/boot-rp1
  • /flash/boot

The first two I was able to modify via SSH to carry the following lines (I also made sure there were no conflicting directives after them).

# hdmi_force_hotplug=1
hdmi_ignore_hotplug=1
sdtv_mode=2

But the one in /flash/boot/ is still carrying hdmi_force_hotplug=1 and has the sdtv_mode=2 commented out. So I guess that's the one I should be modifying. But if I try nano complains the file system is write only. Should I change permission for the whole directory, first, or are there more hoops I should be jumping into?

Why should I be jumping through all these hoops? Shouldn't NOOBS be avoiding this by allowing simple switching between devices?

EDITed to remove the long config.txt file, since the problem seems to be elsewhere now. (file can still be seen in the edit history).

  • Does this line: hdmi_ignore_hotplug=1 appear uncommented in your config,txt file – Steve Robillard Dec 28 '15 at 22:16
  • Have you seen this bhavyanshu.me/tutorials/… – Steve Robillard Dec 28 '15 at 22:35
  • 1
    @SteveRobillard yes to both your questions. If I enter via SHIFT into NOOBS recovery mode, I can read the config.txt file and yes, the ignore hotplug line is uncommented and the force hotplug one is commented (I believe I've modified all config.txt I was able to find). Also uncommented is the PAL line. With Raspian - on the same system, fixing config.txt worked. OpenELEC is resistng. And its resistance is not futile. It's actually frustrating. – Sredni Vashtar Dec 29 '15 at 1:11
  • Can you add the full text of config.txt to your question – Steve Robillard Dec 29 '15 at 1:23
  • 1
    Well, I have that too installed. But I would like to use openElec. I already know that the hardware is capable of putting the RCA video out (it works in Raspian) so, what is preventing OpenElec to do the same? I have to know! :-) I will add the config.txt as soon as I figure out how to get it out of PuTTY's window. (I keep forgetting that hitting enter in a comment window will send the comment and not create a new line) – Sredni Vashtar Dec 29 '15 at 1:38
5

For future reference.

OpenELEC config.txt file is in /flash

To modify it, you need to remount the /flash directory as rw, as it is read-only by default. The easiest way to do that is to have both the Pi and another computer on the same network and use SSH.

If you are using Windows, you can use PuTTY: launch the exe, put the IP address of your Pi (you can read it in the network connections page of your router, or in the System>System Info page of OpenELEC), let's say it's 192.168.0.3. Click on connect in Putty's window and you will be presented with a console.

Enter root as user, and openelec as password. You will be presented with a console-like window.

Now, remount /flash as read-write

mount -o remount,rw /flash

and launch nano to edit your config.txt file

nano /flash/config.txt 

Now, to make your OpenELEC switch to PAL when there is no HDMI cable connected to your Pi, I suggest you modify the last lines to show

# hdmi_force_hotplug=1
# hdmi_ignore_hotplug=1
sdtv_mode=2

The first one needs to be commented out so that the Pi won't always force HDMI output. The second one I like it to have it commented out (or not there at all) so that the Pi won't always force composite video output, regarless of the presence of an HDMI cable plugged in. The third line tells the Pi to use PAL video output.

Once your are done modifying config.txt, press CTRL+x to exit, then Y to confirm you want to save the changes and ENTER to overwrite the config.txt file.

We're almost done: all we have to do now is to make /flash read-only again.

mount -o remount,ro /flash

and then we can reboot

reboot  

Close Putty's window and enjoy your OpenELEC on an HDMI TV when the HDMI cable is plugged in or on your old analog TV when there is no HDMI cable in and you have you TV hooked up via the yellow RCA connector. Audio signal will have to be tapped from the 3.5mm jack connector.

And you are hopefully done jumping through hoops.


EDIT

When I bought a Raspi3B+ I was faced with the same problem but now there is a much easier way to do it if you have NOOBS installed.

At boot, enter the Recovery Mode by pressing "SHIFT" Choose the OS you want to see on your TV from the list and then click on the Edit tab to edit the config.txt e cmdline.txt files.

As said above, make sure the following lines, if present at all, are commented out like this:

# hdmi_force_hotplug=1
# hdmi_ignore_hotplug=1

and add the line

sdtv_mode=2

(2 stands for PAL) For good measure, if you are experiencing problems with the audio (like it came from underwater), add this line too:

audio_pwm_mode=2

Also, once in Kodi go to the GUI menu System, Settings, System, Audio and set "Audio output device" to "Pi Analogue". This has solved most of my audio woes.

1

An easier way: Take out the SD card from RPi, mount it on a PC (or any Operating System), do the editing, unmount the SD card and go back to RPi.

  • I guess this is simpler, but it was not a viable option to me for very specific reasons: my PC does not have a built-in card reader and the external one I bought (Transcend) only works on Winduh (which is not capable to see the ext partitions). It would work on Linux but requires a newer Linux kernel, so I was (am) temporarily unable to access the card (I cannot even update OpenELEC since I have no means to transfer the new 116MB file on the SDcard - and no, net sharing doesn't work either). I have a really ****-up configuration right now, I know.... – Sredni Vashtar Mar 19 '16 at 13:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.