2

When I tried to install Raspbian Jessie, on the first boot my Raspberry Pi 2 got stuck on:

"A start job is running for LSB: Set console font and keymap"

  • Welcome to the Raspberry Pi SE Community. I do agree that looks as though something is not going according to plan - my first install was done blind (my "Second User" Pi has a faulty HDMI output) and I do recall it took ages as the NOOBS/Raspbian setup does need to juggle things around on the SD card on the first occasion (resizing partitions); that doesn't seem to be the case for you, so let's see if someone else can point you in the right direction... – SlySven Dec 28 '15 at 20:09
  • So the problem is from my SD card ( TDK 8Go class10 ) ? ( when i try to use NOOBS 1.5, it crashed before i can select a OS to install ) – unluckylemon Dec 28 '15 at 23:42
  • That sounds as though it ought to be an Ok card - there is a list somewhere of good/bad ones - use the search box in the top right of the screen to see if you can find it. I'd wonder more about the Power Supply - and what peripherals that are plugged into the Pi's four own USB ports (NOT plugged into a Powered HUB attached to one of those four) the power that those four can supply to USB devices is a bit limited. – SlySven Dec 28 '15 at 23:57
  • In fact, Raspbian Wheezy ( 2015-05-05 ) work, but when i do apt-get update/upgrade and reboot the rpi, it crash on boot. Are there a way to skip a step in boot of raspbian ? – unluckylemon Dec 29 '15 at 1:03
1

This is a link to a list of SD card's.

http://elinux.org/RPi_SD_cards

0

For what its worth I had this exact same problem. I tried swapping all peripherals, two different Pi 2 Model B's, different power supplies and two different cards. These combinations had all worked fine with Wheezy but didn't play ball when it came to running Jessie - both an upgraded version and a clean downloaded image.

Boot Screen

I came across this post and although I had tried two different cards they were both the same make/model (Delkin Micro SDHC 8GB class 10). I also noticed that the green ACT LED stayed on solidly once the boot process hung. So the final thing I tried was swapping in a third SD card from a different manufacturer - an SanDisk Ultra I had previously used for a GoPro. This booted up first time! It would therefore seem that the newer Raspbian images are much more sensitive to the type of card used.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.