I plugged in my pi to my hdmi screen and I've been getting a screen with just lines on it going up to down. It makes sense as this hdmi screen does not have a video scaler so unless you get the resolution right there could be some issues... The guide to the screen which can be found here: https://learn.adafruit.com/adafruit-5-800x480-tft-hdmi-monitor-touchscreen-backpack/raspberry-pi-config says to use the config.txt file to change the settings around... I can't seem to find a boot folder on my sd card. Here is a picture of the contents:enter image description here

  • You are probably not seeing the whole SD Card, that looks like the first partition which is a small ExVFat(?) partition that NOOBS uses to hold ITS stuff. You can add a config.txt to that directory which (I think) NOOBS will use on startup. If you are using something like Raspian then that uses other partitions (by default a ext2/ext3 or ext4 filesystem) which Windows does not understand without extra drivers. – SlySven Dec 29 '15 at 19:02

That is the boot partition. Because you are using a Windows PC, you can only see the FAT formatted boot partition, and not the other ext2 (linux) formatted parition(s). You can simply add a config.txt file to the directory you are looking at.

  • And that's not right given the partitioning of noobs, see here: github.com/raspberrypi/noobs/wiki/NOOBS-partitioning-explained The boot partition FAT where config.txt resides will not be shown on Windows as that only shows the first partition. Which happens to be also a FAT partition but of relevance for NOOBS not the respective OS. – Ghanima Aug 28 '16 at 21:12
  • @Ghanima NOOBS boot is more complicated than I realised! Still, unless I'm mistaken the config.txt will always be on the first partition, which is what this is (/dev/mmcblk0p1). The booting pi can only read FAT formatted partitions, which windows can also see. EDIT: See here for reference to location of config.txt : raspberrypi.org/documentation/configuration/config-txt.md and note the presence of bootcode.bin and start.elf. – js441 Aug 28 '16 at 21:18
  • Well, then this boils down to the fact that I do not know enough about NOOBS either ;) (or put differently I do not have a NOOBS running to check right now). From the documentation I always assumed that each OS on NOOBS has its own FAT including its specific config.txt. – Ghanima Aug 28 '16 at 21:28
  • Consider the page linked above saying It does this by reading the settings partition to determine the boot partition for that OS, and then instructs the firmware to "soft-reboot" using the OS's boot partition. This then 'reboots' the firmware and loads start.elf from the specified partition (typically /dev/mmcblk0p5 if only one OS is installed) and then proceeds the same as the standalone boot described at the very top of this page - start.elf loads kernel.img and reads cmdline.txt. start.elf sits in the respective boot partition of any OS, as does config.txt. – Ghanima Aug 28 '16 at 21:30
  • In that case, I have no idea. I assume until an OS is installed it will use this boot partition though, which should allow the HDMI settings to be set - even if they are overwritten later. I'll test as soon as I can. – js441 Aug 28 '16 at 21:34

I believe that is an unused NOOBS card, as it is identical to what's shown here.

Of course, this puts you in a bit of a circular bind, because to install an actual OS so you can adjust config.txt you need the display to work. I realize NOOBS may come with Raspbian pre-installed but I'm guessing you still have to go through the initial OS selection procedure.

However, according to this Q&A, NOOBs uses hdmi_force_hotplug by default, and if you look at rob's answer there seems to be a means of selecting safe_mode, which should work with just about anything.

Another answer there mentions a noob.config file although you do not appear to have one. You might consider poking into that os folder, but I would first try plugging it in, and hitting 2 if the display is blank.

  • I have booted it up to an HDMI monitor before but the noobs didn't let me configure anything.. It just booted into desktop mode... I don't know where to make the config file because there's no boot file @goldilocks♦ – Harry Merzin Dec 29 '15 at 16:41
  • That pic is from a windows machine with the card in it, right? If you can boot up to a desktop on the pi, have you tried looking for a /boot there? The partition should be mounted that way. – goldilocks Dec 29 '15 at 16:46
  • I've tried to look for boot there but i still cannot find it... Is there a way to make a boot folder? If so where would I make it @goldilocks – Harry Merzin Dec 29 '15 at 17:09
  • It won't work that way. Normally on Raspbian the /boot folder is used as a mount point (Windows doesn't use these, so it may be a new concept) for the first partition on the card. This means it will appear to contain the contents of that partition when the system is running, but empty when not (e.g., if you stick the card in another machine). – goldilocks Dec 29 '15 at 17:21
  • I'm actually not a NOOBs user, I just thought I'd try and provide a quick answer...I suggest you write another question and, since you can boot the system, ask how you can find what you are looking for from Raspbian on NOOBs (i.e., don't include a windows screenshot). – goldilocks Dec 29 '15 at 17:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.