1

i have rpi with jessie release, i can ssh to it through ethernet as i have forced static ip, but i cant ssh to it through wifi. Wifi conection is configured (ssid and psk) and rpi is connected to it. When i execute in my PC command:

nmap -sP 192.168.1.1/24

it finds all devices connected to wifi except raspberry.

I have tryed to force static IP with wifi connection in etc/network/interfaces but then i get no wireless interfaces were found

i have raspberry connected to tv but no keyboard or mouse are available

etc/network/interfaces:

auto lo
iface lo inet loopback

auto eth0
allow-hotplug eth0
#iface eth0 inet manual
iface eth0 inet static
address 192.168.1.188
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.254



auto wlan0
allow-hotplug wlan0
iface wlan0 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

auto wlan1
allow-hotplug wlan1
iface wlan1 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

result of lsusb:

Bus 001 Device 004: ID 0a5c:bd1e Broadcom Corp. 
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub`

etc/wpa_supplicant/wpa_supplicant.conf:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
    ssid="test-network"
    psk="testpasswd"
}

ifconfig:

eth0      Link encap:Ethernet  HWaddr b8:27:eb:66:da:a2  
      inet addr:192.168.1.188  Bcast:192.168.1.255  Mask:255.255.255.0
      inet6 addr: fe80::ba27:ebff:fe66:daa2/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:583 errors:0 dropped:0 overruns:0 frame:0
      TX packets:422 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:53261 (52.0 KiB)  TX bytes:47466 (46.3 KiB)

lo        Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:243 errors:0 dropped:0 overruns:0 frame:0
      TX packets:243 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:21778 (21.2 KiB)  TX bytes:21778 (21.2 KiB)

wlan0     Link encap:Ethernet  HWaddr fc:b4:e6:bf:a0:d3  
      inet addr:192.168.1.58  Bcast:192.168.1.255  Mask:255.255.255.0
      inet6 addr: fe80::feb4:e6ff:febf:a0d3/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:140 errors:0 dropped:2 overruns:0 frame:0
      TX packets:49 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:12631 (12.3 KiB)  TX bytes:9147 (8.9 KiB)

Problem got kinda solved, still dont know what caused it but here are attempts to fix and fix:

  1. checked if wifi is enumerated with lsusb, it was enumerated.
  2. in etc/network/interfaces changed iface wlan0 inet manual to iface wlan0 inet dhcp -> reboot.
  3. with dhcp set no wireless interfaces were found
  4. tryed sudo service sshd restart got dhcpcd not running info when hovered over connection icon
  5. in /etc/ssh/sshd_config uncommented line ListenAddress 0.0.0.0 then reboot and try ssh again, didnt work.
  6. checked wifi dongle on windows 7 and ubuntu 14, worked fine, changed charger to 5V/2A, but still didnt solve anything.

These steps should have solved my problem but they didn't, so i copied to desktop and reverted all changes made to wpa-supplicant and interfaces, connected a touchscreen to rpi andconnected with graphic interface by copyiong psk from wpa-supplicant on desktop. Everything worked fine. I compared working wpa supplicant and interfaces with not-working ones but they where identical, dont know what caused my problem but using graphical interface fixed it.

  • Is your wiFi enumerated by the Pi? What is the output of lsusb? – Steve Robillard Dec 29 '15 at 23:24
  • how to check if its enumerated? i edited the post with result of lsusb – Cynizm Dec 29 '15 at 23:38
  • 1
    To verify it is enumerated remove the dongle and rerun lsusb if you have a missing entry comapred to the above you know that it is being enumerated. I suspect that the first line above is your WiFi dongle. Please add /etc/network/interfaces and /etc/wpa_supplicant/wpa_supplicant.conf and ifconfig to your question – Steve Robillard Dec 29 '15 at 23:48
  • yes, its enumerated. added missing info. – Cynizm Dec 30 '15 at 0:01
  • Can you SSH pi@192.168.1.58 – Steve Robillard Dec 30 '15 at 0:05
1

You have to decide what you want to do.

If you want to use the WiFi config in the GUI (which is where the no wireless interfaces were found message comes from) you MUST use dhcpcd.

If you want to configure it in the old way, disable dhcpcd (which is what happens if you use dhcp), although you should do this properly.

If you want to set static IP you must do it the dhcpcd way.

See the following for a description of how to setup dhcpcd. How do I set up networking/WiFi/Static IP

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.