3

I just purchased a pi 2 through the CanaKit, and I'm having some issues getting the wifi dongle to work. It scans for networks and finds mine, but when I put in the passcode and click "OK," absolutely nothing happens. It never connects to the network, and it never shows anything that suggests that it's attempting a connection, as I expect it would do. I hooked it to an ethernet cable and did sudo apt-get update && sudo apt-get upgrade to make sure everything was up to date, and I verified that the network configuration in /etc/(something)/wpa_supplicant is correct, though still no joy.

Has anyone else experienced this problem? Anyone have an idea as to how I might go about fixing it?

1
  • Please use 'lsusb' (if not available use 'apt-get install usbutils') and post the device/dongle name and description.
    – fcm
    Commented Dec 30, 2015 at 22:45

2 Answers 2

0

I actually just solved this issue. Apparently for WEP networks, you have to remove the quotes from the key in the file /etc/wpa_supplicant/wpa_supplicant.conf (I think that's it, don't have convenient access to my pi right now). Hope this helps someone in the future!

2
  • 1
    It's great that you want to help, but your answer looks misleading to me. According to the official examples, WEP keys should work with or without quotes. Your issue was probably solved by something else. Commented May 31, 2017 at 15:55
  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year.
    – Ingo
    Commented May 6, 2020 at 11:24
0

Try to install wpagui and then use the GUI to setup WiFi network connection:

sudo apt-get update && sudo apt-get install wpagui -y

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.