3

I bought a USB audio adapter and have been unable to get any sound to come out of it.

lsusb reports it as:

Bus 001 Device 005: ID 1b3f:2007 Generalplus Technology Inc.

which is not one I've come across before.

Anyway, I modify /etc/modprobe.d/alsa-base.conf, reboot, run amixer and get the following output:

Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch pswitch-joined penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 30
  Mono:
  Front Left: Playback 27 [90%] [-4.50dB] [on]
  Front Right: Playback 27 [90%] [-4.50dB] [on]
Simple mixer control 'Mic',0
  Capabilities: pvolume pvolume-joined cvolume cvolume-joined pswitch pswitch-joined cswitch cswitch-joined penum
  Playback channels: Mono
  Capture channels: Mono
  Limits: Playback 0 - 14 Capture 0 - 30
  Mono: Playback 0 [0%] [-12.00dB] [off] Capture 26 [87%] [27.00dB] [on]
Simple mixer control 'Auto Gain Control',0
  Capabilities: pswitch pswitch-joined penum
  Playback channels: Mono
  Mono: Playback [off]

I also get the following from aplay -l:

**** List of PLAYBACK Hardware Devices ****
card 0: Device [USB Audio Device], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
  Subdevices: 8/8
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7
card 1: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Looking good, however I get no output when I attempt to play a sound:

pi@raspberrypi ~ $ aplay /usr/share/scratch/Media/Sounds/Vocals/Singer1.wav
Playing WAVE '/usr/share/scratch/Media/Sounds/Vocals/Singer1.wav' : Signed 16 bit Little Endian, Rate 11025 Hz, Mono
aplay: set_params:1087: Channels count non available

I've set the volume on alsamixer high enough so I should be hearing something.

At this point I've no idea whether or not I have a broken USB audio dongle or configured something wrong. Can anyone help?

3

I had exact the same issue with exactly the same USB Soundcard. In my case the service pulseaudio was not running. You can check by entering following command in a terminal window:

 ps -edf | grep pulseaudio

if pulseaudio is running you will see it with its PID. Otherwise try to kill any pulseaudio service by entering

 pulseaudio -k

and restart pulseaudio by entering pulseaudio (in Foreground) or even better (in my case)

 pulseaudio --start

If you want to ensure, that pulseaudio is started when Raspberry boots up, check following link: pulseaudio not autostarting on pi 3.

In the desktop GUI you have then to select USB Audio Device and Verify USB Device Settings. Activate there all options (Mic, Speaker, etc)

enter image description here

Hope this helps in your case.

2

My issue was resolved by following the instructions below for the CM108, even though the USB audio adapter doesn't advertise itself as that type.

https://learn.adafruit.com/usb-audio-cards-with-a-raspberry-pi/cm108-type

In my specific case it was because I hadn't updated the firmware.

This was then further complicated by the fact that I was misled by aplay into thinking that it wasn't working - when it turned out that mpg123 works just fine.

  • Hello and welcome. Thank you for sharing your experience and providing an answer to your own question. If you think it addresses all the issues brought up (and not feeling that additional answers should be encouraged), you can also "accept" your own question after some grace period. – Ghanima Jan 1 '16 at 14:01
1

I had this exact issue as well with my Raspberry Pi Zero W. Turns out, thanks to The above reference to starting pulseaudio... I realized pulseaudio wasn't installed by default (on at least the RetroPi 4.3 distro).

Preformed a 'sudo apt-get install pulseaudio' and I now have something that resembles sound... Choppy, But that could be the emulator or something else. Now, On to investigate that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.