2

So, I've scoured the forums and tried everything (of which I'm aware) under the sun and, well, I've come up empty. Just purchased a new Logitech K400 Plus Keyboard and wanted to connect to my Raspberry Pi 2. The USB receiver isn't recognised. It's listed in a lsusb but, hcitool scan reveals nothing. Any tips on how to proceed as I've reached an impasse. Rather not order a different wireless keyboard if, in fact, there's a workaround.

1
  • What OS are you using I have one of these and have used it with both Raspbian Jessie and Ubuntu mate with no configuration at all. Have you tried it in another computer? To rule out the obvious, have you checked the poqer switch. Commented Jan 1, 2016 at 0:49

1 Answer 1

2

Is it the receiver a "unifying nano" receiver or the Wireless keyboard that is not being recognised?

As this is a New unit, I hope you have checked that there is not an insulated strip between one of the batteries and the corresponding contact in the keyboard?

I was looking at a related Logitech device this afternoon as I have a mouse from the same manufacturer but I've mislaid the dongle - and they are already paired up before they get packaged so you shouldn't need to have to do this. Which is just as well, as, apparently, Logitech do not support Linux OSs with most of their 2.4GHz wireless products and so there is no "Manufacturer Provided" software to do manual pairing (or report the battery status of paired devices). However there are some third-party reverse-engineered Linux things, such as solaar to do this.

It is possible to do any needed pairing operations, with the software provided, on a PCWindows/Mac and those pairing are "remembered" unless overwritten by rerunning that software...

4
  • No need for pairing the K400 is a combined keyboard and trackpad with a single receiver. Commented Jan 1, 2016 at 0:51
  • Yeah - it should work "out of the box"! But if it doesn't it is a lot harder to match the keyboard / trackball / mouse to the unifying-nano receiver or check what is going on with a Linux Host compared to a Windoze or Mac one - unless you have a third-party utility or a Win/Mac box with the Logitech Unifying software. 8-(
    – SlySven
    Commented Jan 1, 2016 at 1:38
  • He doesn't mention OS but I am running one of these without issue. I am guessing battery or power switch issues if not a defective unit. Commented Jan 1, 2016 at 1:42
  • Hence my question about an insulated strip - I distinctly remember there being one on/in the mouse I bought a while back! 8-P
    – SlySven
    Commented Jan 1, 2016 at 2:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.